Can I edit mcreator 1.7.9 RAM amount without launching it?

Started by mc85 on Tue, 05/08/2018 - 20:04

Topic category: Help with MCreator software

Last seen on 22:17, 28. Jun 2018
Joined Jul 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Can I edit mcreator 1.7.9 RAM amount without launching it?
Tue, 05/08/2018 - 20:04

My mcreator keeps running out of RAM during startup, is there a way for me to fix this?

Last seen on 16:41, 29. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Check this issue for more…
Tue, 05/08/2018 - 20:24

Check this issue for more information: https://mcreator.net/tracker/issue/40598

From MCreator 1.7.8 on, there is not more such file. Now, you need to do the following. Go to your user home folder of the system you use. Here find the folder .mcreator. Go in it. You should find a file called preferences. If there is no such file, create one and give it no extension - the whole file name should be preferences.

If there is already a file, open it and look for the parameters "xms": and "xmx": and set them to the appropriate values. If there is no file, create one with the following contents:

{"gradle":{"xms":1024,"xmx":2048,"offline":false}}

Set the xms and xmx parameters to the desired values, but keep in mind that setting too high value may also cause issues on 32 bit systems.

Last seen on 22:17, 28. Jun 2018
Joined Jul 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Now all versions of mcreator…
Wed, 05/09/2018 - 01:04

Now all versions of mcreator (1.7.9 and below) are encountering gradle errors. I am running 32 bit 1.7.9 on a 64 bit computer, but this is because 64 bit keeps defecting. I have a zipped 64 bit file if it needs to be reviewed.