Mcreator 1.8.9 doesn't work

Started by Raine on Thu, 06/14/2018 - 02:59

Topic category: Help with MCreator software

Last seen on 18:00, 15. May 2020
Joined Jun 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Mcreator 1.8.9 doesn't work
Thu, 06/14/2018 - 02:59

Hi everyone. First i just want to say that, i've likely gone crazy with this. Looking down at the clock it's been roughly 6 hours with messing around with this program. I get "Could not connect to the Pylo Server. Some Functions might not work!". I can't log into the client, it keeps saying my password is wrong so i just hit "Skip". Ultimately, when i try to recompile and export a mod, i get the same annoying message over and over "Your mod contains errors and could not be exported. No mod file was generated.". I get this message even if i don't add any new elements. I've tried the disconnecting the internet thing and that doesn't work. Funny part is, if i use the newer 1.12.2 Mcreator, everything works fine.. But the 1.8.9 one doesn't work. I don't like 1.12.2 and only use 1.8.9 in single player so i cannot do anything anymore. I do remember being able to use it though several months ago. But not anymore. If you can guys can quickly point out why, i'd appreciate it very much. Thanks.

Last seen on 18:00, 15. May 2020
Joined Jun 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Oh and, i am using version …
Thu, 06/14/2018 - 03:06

Oh and, i am using version "1.6.6 [1.8.9] Windows 64bit by the way. In the console i see this

Fatal Error] lzma-0.0.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] vecmath-1.5.2.pom:2:1: Content is not allowed in prolog.
[Fatal Error] twitch-platform-6.5.pom:2:1: Content is not allowed in prolog.
[Fatal Error] twitch-external-platform-4.5.pom:2:1: Content is not allowed in prolog.
FAILURE: Build failed with an exception.
* What went wrong:
Could not resolve all dependencies for configuration ':forgeGradleMcDeps'.
> Could not resolve lzma:lzma:0.0.1.

So much scratching my head and wanting to bite my finger nails off. Is it because they're just not supported anymore? If that's the case then there's no way to make mods anymore for the version i most use.

Last seen on 13:06, 22. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It seems like the firewall…
Thu, 06/14/2018 - 07:22

It seems like the firewall is blocking some parts of MCreator. Or it could be the antivirus.

Last seen on 18:00, 15. May 2020
Joined Jun 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hi Klemen. I've tried…
Thu, 06/14/2018 - 14:59

Hi Klemen. I've tried unblocking it with windows firewall but that was a no-go. My antivirus is disabled by the way.

Last seen on 13:06, 22. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Please try to do the…
Thu, 06/14/2018 - 18:25

Please try to do the following:

Go to C:\Users\<YOUR USERNAME>\.mcreator\gradle\ and remove the caches folder. Then, try to run MCreator again.

Last seen on 18:00, 15. May 2020
Joined Jun 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Klemen, thank you very much…
Fri, 06/15/2018 - 16:16

Klemen, thank you very much for your assistance. I have tried your suggestions and i was able to create/export now. :)