Unable to finish installation

Started by Hiveguy on Sun, 02/03/2019 - 07:43

Topic category: Bugs and solutions

Last seen on 06:34, 15. Aug 2019
Joined Feb 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Unable to finish installation
Sun, 02/03/2019 - 07:43

So recently i decided to install mcreator again after not using it for months, i've been unsuccessful at being able to actually get into using it. I've tried my best to find a solution but everything i havent tried works. Here is my problem:
   
Executing gradle command: wrapper --gradle-version 4.4
Build info: MCreator 1.8.2, 64-bit, 12186 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=true -Dorg.gradle.parallel=true -Dorg.gradle.jvmargs="-Xms2000m -Xmx5000m" wrapper --gradle-version 4.4 
Starting a new Gradle Daemon for this build (subsequent builds will be faster).
FAILURE: Build failed with an exception.
* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at https://docs.gradle.org/2.14/userguide/gradle_daemon.html
Please read the following process output to find out more:
-----------------------
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size
Picked up _JAVA_OPTIONS: -Xmx512M
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Picked up _JAVA_OPTIONS: -Xmx512M
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 3904 milliseconds
   
Executing gradle command: setupDecompWorkspace --refresh-dependencies
Build info: MCreator 1.8.2, 64-bit, 12186 MB, Windows 10 - cmd, JVM 1.8.0_192, JAVA_HOME: C:\Pylo\MCreator182\.\jdk
C:\Pylo\MCreator182\forge>gradlew -Dorg.gradle.daemon=true -Dorg.gradle.parallel=true -Dorg.gradle.jvmargs="-Xms2000m -Xmx5000m" setupDecompWorkspace --refresh-dependencies 
Starting a new Gradle Daemon for this build (subsequent builds will be faster).
FAILURE: Build failed with an exception.
* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the user guide chapter on the daemon at https://docs.gradle.org/2.14/userguide/gradle_daemon.html
Please read the following process output to find out more:
-----------------------
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size
Picked up _JAVA_OPTIONS: -Xmx512M
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Picked up _JAVA_OPTIONS: -Xmx512M
C:\Pylo\MCreator182\forge>
Task completed with return code 0 in 2312 milliseconds

Last seen on 19:46, 28. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Set minimal RAM in…
Sun, 02/03/2019 - 10:39

Set minimal RAM in preferences to around 1GB and maximal to around 4GB and run the setup again.

Last seen on 06:34, 15. Aug 2019
Joined Feb 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
how much would that exactly…
Sun, 02/03/2019 - 12:02

how much would that exactly be in the preferences (sorry i'm not very inclined with this kind of stuff)
also now its taking forever for caching decompiled code with this in the console