Even more strange stuff after importing old workspace

Started by _Fa11out_ on Mon, 03/25/2019 - 16:06

Topic category: Bugs and solutions

Last seen on 10:45, 14. Apr 2019
Joined Nov 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Even more strange stuff after importing old workspace
Mon, 03/25/2019 - 16:06 (edited)

I decided to update Mcreator, but before this i have exported my workspaces(.mcr) for a backup.
So after installation of new version. While importing it skipped some of mod elements, and the most strange is most of elements are not shown(exept textures).
And there is more: in CODE EDITOR there are every single piece of my mod.

In loaded test workspace my stuff is not shown as in workspace code editor, even procedures are not working.

Current workspace screenshot, just a few elements

A "real" workspace screenshot, there are a lot of elements, recipes and etc...

Problems like this one really "turns me off" for mod development...
P.S. Import "failure" happens only with this one workspace
P.S.2: If exported workspace is damaged, is there any way to restore it somehow ?

Edited by _Fa11out_ on Mon, 03/25/2019 - 16:06
Last seen on 13:02, 21. Apr 2019
Joined Apr 2010
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
  • developer
No, we can't restore damaged…
Mon, 03/25/2019 - 16:44

No, we can't restore damaged workspaces. You can open a support ticket and attach the workspace you are trying to import so we can see what can be done.