Need help with creating some blocks Minecraft ver. 1.8

Started by Ameal on Wed, 06/12/2019 - 10:28

Topic category: Help with MCreator's application

Last seen on 07:59, 13. Jun 2019
Joined Jun 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Need help with creating some blocks Minecraft ver. 1.8
Wed, 06/12/2019 - 10:28

  I'm 100% new to minecraft modding. I have a vague understanding of Gimp. I've retextured Stardew Valley, Skyrim, and the Sims 3 for personal use. Zero model experience.

I basically want to duplicate the cauldron(it's functionality) and carpet. Then retexture them to look like a sink and the stone slab. I've already got my sink texture ready. Don't know how the game reads the carpet files though.

I tried to make a simple block but I think MCreator is crashing when I try to "Export the mod"; it closes seconds after I click "recompile and export". It's not exporting to the designated location either. I tired to take the assets folder from: MCreator\forge\src\main\resources and put it in the .minecraft mods folder as a .jar, .zip and folder. None of this worked.

This is my first time using MCreator 1.6.4 and it's confusing. To make matters worse I can't find any tutorial for the cauldron or carpet with this version. I'm playing minecraft 1.8 because of an old map that doesn't want to update without breaking.

Sorry if this is confusing but I'm confused by all this!!!!

Last seen on 17:13, 16. Jun 2019
Joined Apr 2010
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
  • developer
MCreator 1.6.4 is outdated…
Wed, 06/12/2019 - 14:32

MCreator 1.6.4 is outdated and you won't get support for this version here. We have fixed these bugs in later versions.

Last seen on 07:59, 13. Jun 2019
Joined Jun 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Okay then are any of the…
Wed, 06/12/2019 - 19:59

Okay then are any of the later MCreator versions compatible with Minecraft 1.8?

Last seen on 17:14, 16. Jun 2019
Joined Dec 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MCreator 1.6.6 is the latest…
Thu, 06/13/2019 - 14:57

MCreator 1.6.6 is the latest version for 1.8.9 which belongs in 1.8 anyway, but if you need a 1.8 version, there's no newer one.