1.12.2 Client Broken

Started by deningtongaming on Tue, 10/08/2019 - 22:59

Topic category: Bugs and solutions

Last seen on 00:53, 14. Nov 2019
Joined Oct 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
1.12.2 Client Broken
Tue, 10/08/2019 - 22:59

Sorry if this is the in-correct place to post this but I felt it was necessary.
My 1.12.2 client has broken, completely!

 

The first launcher to not work was the "default" Minecraft Launcher with loading the 1.12.2 profile it ended up loading 1.14.4-fabric, in clear words 1.12.2's profile was launching the most-recent launch of the game prior to that.

Then out of no-where after trying "twitch" Launcher it also crashed, not sure why..

But now I went to design my mod on MCreator, "Dencraft" -Name is not final, but once I got to launching the game it chucked an error out at me.

FAILURE: Build failed with an exception.
* What went wrong:
Could not determine the dependencies of task ':compileJava'.
> Could not create service of type AnnotationProcessorDetector using JavaGradleScopeServices.createAnnotationProcessorDetector().
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
BUILD FAILED in 50s
D:\MCreatorWorkspaces\DenCraft>
Task completed with return code 0 in 51449 milliseconds
 

I was considering not posting this here on MCreator however it is an MCreator log I am detailing so I proceeded.

Another note: 1.14.4 and Fabric are both working normal

Last seen on 00:53, 14. Nov 2019
Joined Oct 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Edit: I have resolved this…
Wed, 10/09/2019 - 04:19

Edit: I have resolved this issue by deciding to start my mod again.
For the normal game and twitch launcher's I am not sure.

Please delete/close or whatever this post!
~~Thank you~~