I need help updating a mod

Started by KenAsul on Sat, 02/08/2020 - 10:10

Topic category: Help with modding

Last seen on 20:06, 30. May 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
I need help updating a mod
Sat, 02/08/2020 - 10:10

Hey I need help updating a mod, I made this https://mcreator.net/modification/45557/minecraft-roleplay-mod , and was wondering if I could update it from 1.12.2 to 1.14.4. I have the mcr file but I don't know what to do with it.

Last seen on 19:08, 30. May 2020
Joined Aug 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
You have all Forge versions…
Sat, 02/08/2020 - 12:06

You have all Forge versions in your Workspace settings. Click on the Forge version and change it for 1.14.4 Forge.

Last seen on 14:58, 30. May 2020
Joined May 2014
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
If you have an MCR file,…
Sat, 02/08/2020 - 23:42

If you have an MCR file, then first you'll have to download MCreator 1.8.3, load it in, then export it as a .ZIP workspace. MCreator no longer supports MCR.

Second, to change the forge version you go up to the top left-ish to the workspace tab, then click the forge version and change it like Goldorion said. I will warn you though that custom coded mod elements will need to me migrated to the new version manually because they don't like to compile when switching versions.