Confused about Item addition

Started by chaoticDreemur on Sun, 03/08/2020 - 17:07

Topic category: Help with modding (Java Edition)

Last seen on 22:15, 18. Mar 2020
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Confused about Item addition
Sun, 03/08/2020 - 17:07

I am trying to add custom weapons (mostly swords) to the game. The problem is when testing the mod in-game, it crashes the second the custom weapon touches an entity. I don't know what is wrong but what I did to deal damage to an entity is

I went into "When mob is hit with tool"

and then when it loaded the code blocks, I set the green starter one to "Entity Attacked"

and then added a block from the entity section labeled as: Deal __ damage to provided entity and set it to 4.

If anyone could help me, that would be very appreciated!

Thanks in advance!

 

Last seen on 06:46, 21. Aug 2020
Joined Feb 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
you dont need to set green…
Mon, 03/09/2020 - 10:22

you dont need to set green starter. It works when you put it in "When mob hit with tool". Try setting it in "no additional trigger" at green starter

Last seen on 22:15, 18. Mar 2020
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I did that and the game…
Mon, 03/09/2020 - 20:03

I did that and the game still crashes

Last seen on 22:15, 18. Mar 2020
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Update: everything custom…
Mon, 03/09/2020 - 20:08

Update: everything custom crashes the game. Smelting the new ore crashes the game, using the swords crashes the game. The only thing that doesn't is crafting.