Obj models are not showing since 2020.1 update...

Started by alparda112 on Thu, 05/21/2020 - 14:33

Topic category: Bugs and solutions

Last seen on 13:57, 12. Jul 2020
Joined Oct 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Obj models are not showing since 2020.1 update...
Thu, 05/21/2020 - 14:33

Since 1.4.4 update I can't use obj models they give me a purple and black texture error. I tried almost everything and still cannot make obj models work on mcreator... Anyone knows something about this problem?

Last seen on 02:04, 13. Jul 2020
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
OBJ models are experimental…
Thu, 05/21/2020 - 14:45

OBJ models are experimental and don't really work. I recommend just using .json models.

Last seen on 00:36, 13. Jul 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
did you triangulate faces…
Thu, 05/21/2020 - 15:01

did you triangulate faces and joined parts?

Last seen on 13:57, 12. Jul 2020
Joined Oct 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
As you said I triangulated…
Fri, 05/22/2020 - 13:28

As you said I triangulated faces. Thanks to your advice now I can see the 3d shape ingame. However this time it shows up in grey... Thanks a lot for your help.

Last seen on 00:36, 13. Jul 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
i dont think the textures…
Fri, 05/22/2020 - 16:49

i dont think the textures would EVER show up...

Check the console log on…
Fri, 05/22/2020 - 17:34

Check the console log on more info (look for warnings on textures).

But I would highly recommend using JSON instead, OBJs are very experimental thing.

Last seen on 18:22, 11. Jul 2020
Joined May 2014
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
This is unfortunate. I am…
Fri, 05/22/2020 - 19:00

This is unfortunate. I am also stuck in this situation simply because I wanted 2 axes of rotation. Apparently this is just too much for JSON. My model worked until I updated to 1.14 and now it is permanently broken. I now have to use trickery like entities shaped like blocks and such. 

Probably this:     [Server…
Sat, 05/23/2020 - 16:10

Probably this:

  1.     [Server-Worker-3/ERROR]

  2.     [minecraft/AtlasTexture]:

  3.     Using missing texture, unable to load survive:textures/items/luckring.png

  4.     : java.io.FileNotFoundException: survive:textures/items/luckring.png

  5.  

  6. 33:36.56

  7.     [Server-Worker-7/WARN]

  8.     [minecraft/AtlasTexture]:

  9.     Texture survive:items/grapplinghook with size 316x316 limits mip level

  10.     from 4 to 2

  11.  

  12. 33:36.56

  13.     [Server-Worker-7/WARN]

  14.     [minecraft/AtlasTexture]:

  15.     Texture survive:items/aabatteries with size 225x225 limits mip level from

  16.     2 to 0

Last seen on 00:36, 13. Jul 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
I've checked on them before,…
Sat, 05/23/2020 - 23:46

I've checked on them before, those are not the ones

java.io…
Sun, 05/24/2020 - 08:46

java.io.FileNotFoundException: survive:textures/items/luckring.png

This clearly indicates missing texture, fix this first, render system is sensitive to things like this.

Last seen on 00:36, 13. Jul 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
i've deleted that element…
Sun, 05/24/2020 - 12:33

i've deleted that element and that texture, but the problem still persists, cand i cant determine whats still using the texture