JSON Model is corrupt no matter what i do to fix it

Started by Flying Gorilla… on Wed, 07/29/2020 - 12:46

Topic category: Troubleshooting, bugs, and solutions

Last seen on 13:00, 6. Oct 2020
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
JSON Model is corrupt no matter what i do to fix it
Sat, 08/01/2020 - 08:55 (edited)

Hi, im trying to model in JSON and the entire model doesn't load and its just the corrupt Purple and Black Texture, i tried to put the texture in a texture pack and still the same? please can i have a fix because i am working on a mod and this is a issue that i can't deal with because it makes it more realistic.

Broken:https://ibb.co/WBnvzqX

How it is meant to look like:https://ibb.co/ZmPqwFq

Note: In block bench i set its self as its parent model so that's why it was broken, i'm too used to making entity models.

Edited by Flying Gorilla Games TM on Sat, 08/01/2020 - 08:55
Last seen on 17:57, 21. Aug 2021
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The issue is caused by not…
Wed, 07/29/2020 - 12:58

The issue is caused by not correctly importing the textures for your blocks. You probably didn't select the texture for your custom elements somewhere, and that's what causes you to see the missing textures.

The solution to this problem…
Wed, 07/29/2020 - 17:51

The solution to this problem and many other problems can be found in our knowledge base: https://mcreator.net/support/knowledgebase Please check the knowledge base before opening a new topic on the issue which has a known fix.

Last seen on 13:00, 6. Oct 2020
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
the entire model a square…
Thu, 07/30/2020 - 14:11

the entire model a square instead of what i modeled it as

Last seen on 13:00, 6. Oct 2020
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I Don't blame you if you don…
Thu, 07/30/2020 - 15:29

I Don't blame you if you don't know why it is like this, if you do, you are the best

Last seen on 17:57, 21. Aug 2021
Joined Jun 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The model looks square…
Fri, 07/31/2020 - 14:57

The model looks square because of how the corrupt textures are displayed. I believe that your model is the correct shape, just something happened while you were importing it.

I'll try to explain step-by-step:

1. Export the file as a json (you got this) from Blockbench, as well as all the textures you need.

2. Import all the texture files.

3. Choose import json file from the menu. You should choose your file from the popup.

4. You will be presented with a menu that allows you to choose the mappings for you file. Select all the texture files for the model in the same order that they were in the editor, or it'll look really weird.

5. Click save mappings, and your file should be correctly imported.

6. When you create the block you want in MCreator, it should have the correct textures.

I hope this helps. If not, try rebuilding the code and restarting the app.

Last seen on 13:00, 6. Oct 2020
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
i set the parent model as…
Sat, 08/01/2020 - 07:42

i set the parent model as itself