GUI Causing errors, tried everything. 2020.4

Started by EVG STORE on Tue, 08/11/2020 - 13:14

Topic category: Help with modding (Java Edition)

Last seen on 01:15, 27. Sep 2020
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
GUI Causing errors, tried everything. 2020.4
Tue, 08/11/2020 - 13:14

I have a GUI for a crafting table I made and after watching all the videos it still does not function right. I have a sharable zip to give.

Here is teh sharable zip file (mediafire because i don't know how to upload to this website) https://www.mediafire.com/file/zmrs0sfnma6ezis/Servermod1.15.2.zip/file 

 

Also here is the console text.

Executing Gradle task: build
Build info: MCreator 2020.4.32115, forge-1.15.2, 64-bit, 8053 MB, Windows 10, JVM 1.8.0_252, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk
> Configure project :
New Dep: net.minecraftforge:forge:1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1
> Task :compileJava FAILED
C:\Users\elija\MCreatorWorkspaces\server\src\main\java\net\mcreator\server\gui\ModdedCraftingTableGUIGui.java:204: error: Override is not a repeatable annotation type @Override
^
1 error
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.3/userguide/command_line_interface.html#se…
BUILD FAILED in 1s
1 actionable task: 1 executed
BUILD FAILED
Task completed in 9110 milliseconds
 

Override is not a repeatable…
Tue, 08/11/2020 - 14:44

Override is not a repeatable annotation type @Override

https://mcreator.net/support/knowledgebase

In some cases, Gradle caches that make sure the build process does not take too long can get corrupted. In such a case, go to:

<your user home folder>/.mcreator/gradle

In this folder, there is a folder called caches. Delete this folder and open MCreator again. Next build will take a bit longer as caches need to be rebuilt. If you can not delete all files in this folder (which is necessary), reboot the computer first to remove any potential file locks.

If this is not enough to make things work, delete the entire gradle folder, not just caches, and try again.

If even this fails, try to delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.