Cant run the mod in any way.

Started by Mato879 on Fri, 08/21/2020 - 11:39

Topic category: Bugs and solutions

Last seen on 19:47, 1. Sep 2020
Joined Mar 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Cant run the mod in any way.
Fri, 08/21/2020 - 11:39

So. Yestrday I made a few changes in a mod im working on. But when i tried to test it. I just could run the client.
Big deal i tought so I exported the mod and tested it that way. Minecraft Tried to load but everytime the loading bar hit 100% it just returned to 0%

Mcreator did show a few error messages. But my english isnt that good so i could understand it. (Also i have no idea what it means)

Here is the error.

Task :runClient FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':runClient'.
> Process 'command 'C:\Program Files\Pylo\MCreator\jdk\bin\java.exe'' finished with non-zero exit value -1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.3/userguide/command_line_interface.html#se…
BUILD FAILED in 3m 43s
10 actionable tasks: 4 executed, 6 up-to-date
BUILD FAILED

And here is the Crash Report
 

---- Minecraft Crash Report ----
// Oh - I know what I did wrong!

Time: 21.8.2020 13:15
Description: Rendering overlay

java.lang.RuntimeException: One of more entry values did not copy to the correct id. Check log for details!
    at net.minecraftforge.registries.ForgeRegistry.sync(ForgeRegistry.java:576) ~[?:?] {re:classloading}
    at net.minecraftforge.registries.GameData.loadRegistry(GameData.java:694) ~[?:?] {re:classloading}
    at net.minecraftforge.registries.GameData.freezeData(GameData.java:317) ~[?:?] {re:classloading}
    at net.minecraftforge.fml.ModLoader.finishMods(ModLoader.java:273) ~[?:?] {re:classloading}
    at net.minecraftforge.fml.client.ClientModLoader.lambda$finishModLoading$7(ClientModLoader.java:137) ~[?:?] {re:classloading,pl:runtimedistcleaner:A}
    at net.minecraftforge.fml.client.ClientModLoader.lambda$createRunnableWithCatch$5(ClientModLoader.java:113) ~[?:?] {re:classloading,pl:runtimedistcleaner:A}
    at net.minecraftforge.fml.client.ClientModLoader.finishModLoading(ClientModLoader.java:137) ~[?:?] {re:classloading,pl:runtimedistcleaner:A}
    at net.minecraftforge.fml.client.ClientModLoader.lambda$onreload$4(ClientModLoader.java:107) ~[?:?] {re:classloading,pl:runtimedistcleaner:A}
    at java.util.concurrent.CompletableFuture.uniRun(CompletableFuture.java:719) ~[?:1.8.0_252] {}
    at java.util.concurrent.CompletableFuture$UniRun.tryFire(CompletableFuture.java:701) ~[?:1.8.0_252] {}
    at java.util.concurrent.CompletableFuture$Completion.exec(CompletableFuture.java:457) ~[?:1.8.0_252] {}
    at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289) ~[?:1.8.0_252] {}
    at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056) ~[?:1.8.0_252] {}
    at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692) ~[?:1.8.0_252] {}
    at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157) ~[?:1.8.0_252] {}

A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Thread: Render thread
Stacktrace:
    at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:484)

-- Overlay render details --
Details:
    Overlay name: net.minecraft.client.gui.ResourceLoadProgressGui
Stacktrace:
    at net.minecraft.client.renderer.GameRenderer.updateCameraAndRender(GameRenderer.java:484)
    at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:961)
    at net.minecraft.client.Minecraft.run(Minecraft.java:558)
    at net.minecraft.client.main.Main.main(Main.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at net.minecraftforge.userdev.FMLUserdevClientLaunchProvider.lambda$launchService$0(FMLUserdevClientLaunchProvider.java:55)
    at cpw.mods.modlauncher.LaunchServiceHandlerDecorator.launch(LaunchServiceHandlerDecorator.java:37)
    at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:54)
    at cpw.mods.modlauncher.LaunchServiceHandler.launch(LaunchServiceHandler.java:72)
    at cpw.mods.modlauncher.Launcher.run(Launcher.java:81)
    at cpw.mods.modlauncher.Launcher.main(Launcher.java:65)
    at net.minecraftforge.userdev.LaunchTesting.main(LaunchTesting.java:102)

-- System Details --
Details:
    Minecraft Version: 1.15.2
    Minecraft Version ID: 1.15.2
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_252, BellSoft
    Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), BellSoft
    Memory: 152932360 bytes (145 MB) / 553123840 bytes (527 MB) up to 824180736 bytes (786 MB)
    CPUs: 4
    JVM Flags: 1 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
    ModLauncher: 5.1.2+70+master.2845bb9
    ModLauncher launch target: fmluserdevclient
    ModLauncher naming: mcp
    ModLauncher services: 
        /eventbus-2.2.0-service.jar eventbus PLUGINSERVICE 
        /forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar object_holder_definalize PLUGINSERVICE 
        /forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar runtime_enum_extender PLUGINSERVICE 
        /accesstransformers-2.1.1-shadowed.jar accesstransformer PLUGINSERVICE 
        /forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar capability_inject_definalize PLUGINSERVICE 
        /forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar runtimedistcleaner PLUGINSERVICE 
        /forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-launcher.jar fml TRANSFORMATIONSERVICE 
    FML: 31.2
    Forge: net.minecraftforge:31.2.0
    FML Language Providers: 
        javafml@31.2
        minecraft@1
    Mod List: 
        client-extra.jar Minecraft {minecraft@1.15.2 DONE}
        main Just a few more things {just_a_few_more_things@1.0.0 DONE}
        forge-1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1-recomp.jar Forge {forge@31.2.0 DONE}
    Launched Version: MOD_DEV
    Backend library: LWJGL version 3.2.2 build 10
    Backend API: AMD Radeon HD 8330 GL version 4.5.13447 Compatibility Profile Context 16.300.2401.0, ATI Technologies Inc.
    GL Caps: Using framebuffer using OpenGL 3.0
    Using VBOs: Yes
    Is Modded: Definitely; Client brand changed to 'forge'
    Type: Client (map_client.txt)
    Resource Packs: 
    Current Language: ~~ERROR~~ NullPointerException: null
    CPU: 4x AMD A4-5000 APU with Radeon(TM) HD Graphics 

Last seen on 19:03, 24. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Open bug report, include the…
Fri, 08/21/2020 - 12:26

Open bug report, include the exported shareable workspace ZIP and include as many details as possible