Lots of symbols not found

Started by Lightbulbmaster on Sun, 08/30/2020 - 07:35

Topic category: Bugs and solutions

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Lots of symbols not found
Sun, 08/30/2020 - 07:35

I have an issue where multiple symbols cant be found. Since I dont wanna go through the hassle of posting pictures here I'm gonna type out the error message here and leave a link for the crash log.

 

Main mod file compilation errors                                                            X

Your main mod file did not compile properly.

This is usually caused by inconsistencies in the mod code during builds.                         

MCreator can solve this issue for you by regenerating entire mod's code.

If you have locked mod elements or mod base files, they can cause this error too.

Click Regenerate code button to proceed with this action

             Regenerate code                   Ignore error

 

 

Unfortunatley regenerating the code didnt work and I dont have any mod elements btw.

Here's the crash log: https://pastebin.ubuntu.com/p/vRndhybJVy/

Last seen on 17:12, 24. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try to delete the entire …
Sun, 08/30/2020 - 10:42

Try to delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Going through through the…
Sun, 08/30/2020 - 15:39

Going through through the steps brought back the corrupt gradle cashes I mentioned in my last thread. Not sure what to do know since turning off antivirus completely did nothing.

Here's the crash log: https://pastebin.ubuntu.com/p/t3m9qFkvhR/&nbsp;

Last seen on 17:12, 24. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The error still indicates…
Sun, 08/30/2020 - 15:44

The error still indicates the problem with caches. Try doing this a few more times:

In some cases, Gradle caches that make sure the build process does not take too long can get corrupted. In such a case, go to:

<your user home folder>/.mcreator/gradle

In this folder, there is a folder called caches. Delete this folder and open MCreator again. Next build will take a bit longer as caches need to be rebuilt. If you can not delete all files in this folder (which is necessary), reboot the computer first to remove any potential file locks.

If this is not enough to make things work, delete the entire gradle folder, not just caches, and try again.

If even this fails, try to delete the entire <your user home folder>/.mcreator/gradle folder, create a new workspace with the same generator version as the version of the workspace failing, after the setup of this new workspace is done, open your current workspace, and click Build & run -> Build workspace, then Build & run -> Reload gradle project and then Build & run -> Regenerate code and build.

Also check if your AV could be doing this. If this does not help, I am out of ideas unfortunately.

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Tried all of 'em. It didnt…
Sun, 08/30/2020 - 17:34

Tried all of 'em. It didnt work. I hope it gets fixed in the next update or in some other way. Might not be of interest, but ill leave the latest log here: https://pastebin.ubuntu.com/p/4nn4jPY7fs/

Last seen on 01:43, 23. Oct 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It does not seem like you…
Sun, 08/30/2020 - 19:42

It does not seem like you have experienced the problem since you first downloaded Mcreator

I have another solution that might work for you

Go to your McreatorWorkspaces/<workspace dir>/.mcreator/ folder

Grab the file named FULLBACKUPxxxxxxx for every single workspace

Save the zip files, they will be very important

Delete the entire McreatorWorkspaces folder

Delete another entirely different .mcreator folder in your Home Folder Root

Uninstall Mcreator Completely

Search for leftovers in your computer by typing in Pylo and Mcreator

Stop any firewalls

Stop any anti-virus programs

Reinstall Mcreator

Last seen on 01:43, 23. Oct 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Then import the zipped…
Sun, 08/30/2020 - 19:44

Then import the zipped workspaces you have saved again, see if it helps

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Did all that you said exept…
Mon, 08/31/2020 - 15:08

Did all that you said exept I didnt find the right backup. Dont worry didnt have nothin on the workspace. So I ran the setup and It was apparently succesful but i noticed an exception at the bottom. This was with my security features turned of. Here's the log: https://pastebin.ubuntu.com/p/H4n4r9JnMp/

 

Last seen on 01:43, 23. Oct 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
As long as there are no…
Mon, 08/31/2020 - 15:57

As long as there are no problems with the run, you should be good to go

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Well, I cant start the game…
Mon, 08/31/2020 - 16:06

Well, I cant start the game because then my cashes get corrupt and according to the log there is a missing file

Last seen on 01:43, 23. Oct 2020
Joined May 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try deleteing the entire …
Tue, 09/01/2020 - 22:24

Try deleteing the entire .mcreator/gradle folder again

Last seen on 16:49, 29. Sep 2020
Joined Oct 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I checked. The folder …
Wed, 09/02/2020 - 08:35

I checked. The folder ¨bundled_repo¨ didnt even exist. And after rumaging through the folder i found a version of forge. So I think that the problem is that Mcreator is searching in the wrong directories. Is this something i can fix on my end or does it need fixing from the dev?