Error with custom wire that I don't understand

Started by CyberAssasian on Fri, 09/11/2020 - 21:01

Topic category: Bugs and solutions

Last seen on 20:34, 22. Oct 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Error with custom wire that I don't understand
Fri, 09/11/2020 - 21:07 (edited)

I don't know why, but my custom wire causes an error, perspecificly the procedure. Pastebin of error: https://pastebin.com/Z1AVUnGZ

Workspace: https://drive.google.com/file/d/11WMhlBe9Ai4xlFUj4ujSvO29HjtRMdhx/view?usp=sharing

The code is also very unopimized, so it becoming optimized would be nice.

Edited by CyberAssasian on Fri, 09/11/2020 - 21:07
Last seen on 20:34, 22. Oct 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I've tried: Removing all my…
Fri, 09/11/2020 - 21:16

I've tried:

Removing all my plugins

Duplicate-delete the procedure

 

Last seen on 17:12, 22. Oct 2020
Joined Jun 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It has to do something with…
Sat, 09/12/2020 - 12:41

It has to do something with your Wire Update Tick Procedure and directions. 

Last seen on 20:34, 22. Oct 2020
Joined Aug 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
How do I fix it?
Sun, 09/13/2020 - 16:48

How do I fix it?