Plugin and File Issues on MacOS Operating System

Started by SpaceLazer on Tue, 09/22/2020 - 03:21

Topic category: Plugins and third-party tools

Last seen on 20:23, 26. Apr 2021
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Plugin and File Issues on MacOS Operating System
Tue, 09/22/2020 - 03:21

The GeckoLib plugin for MCreator had a major bug that made it impossible to import JAVA Entities from blockbench. I tried to download and install the newer version of the plugin, but when i installed it MCreator still said i had the old version. So I tried with other plugins and had the same result: installing different versions did not update the version on MCreator. So then i tried locating the plugin files, deleting the plugins and then re-installing the newer versions. So I looked inside of the MCreator app's package contents. There is a plugin folder inside, but the only plugins there are the built-in MCreator defaults, all the other plugins just don't exist in that folder. So I started looking. No trace in Application Support, nothing in the rest of package contents. Nothing in the driver, so I start doing computer-wide searches with Mac's file search feature. Folders with the name "mcreator"? Nothing. Folders with the name "pylo"? Nothing. After searching the forums all help was either useless or unusable for Mac. Nothing else is wrong with MCreator, and it works fine, so none of the other files could be missing.

Does anybody know where MCreator's files are on MacOS? How do I delete plugins?