Custom Mobs are invisible!

Started by TheCatalystGaming on Sat, 10/31/2020 - 21:47

Topic category: Help with modding (Java Edition)

Last seen on 13:59, 19. Jan 2021
Joined Nov 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Custom Mobs are invisible!
Sat, 10/31/2020 - 21:47

I've seen quite a few forum topics on this, however none of them had a good answer on how to fix it. The cubes in Blockbench are in groups, the model is for 1.15 as is the mod itself, but the mob is invisible in-game. Please help! The model's file is provided. https://drive.google.com/file/d/1XikZsl83T-ykGVU5hbmXPo5J36UBydxC/view?usp=sharing

Last seen on 21:26, 20. Jan 2021
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
This happened to me when I…
Sat, 10/31/2020 - 22:42

This happened to me when I set its attack strength to zero and render distance to zero. Change both of those to a nonzero number and you should be good to go

Last seen on 21:26, 20. Jan 2021
Joined Mar 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
And make sure it has a…
Sat, 10/31/2020 - 22:43

And make sure it has a texture and does not attack projectiles

Last seen on 13:59, 19. Jan 2021
Joined Nov 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Thanks, this worked! I've…
Sun, 11/01/2020 - 00:52

Thanks, this worked! I've had this problem for a while now, I think I misinterpreted the render distance field as being how far the mob could see targets, and I had it at 0 as the entity doesn't have AI.

Last seen on 18:00, 4. Dec 2020
Joined Nov 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Hey, I was having a similar…
Sun, 11/29/2020 - 14:22

Hey, I was having a similar issue in that all of my custom mods are mostly invisible with only some textures showing. I've tried it with multiple different mobs and textures but all have the same issue. For this example I made a 5x5x5 block and textured it to look like an eye. When spawned, all the behaviors work and the mob functions normally, it is only the appearance that fails to load. I looked at the console but I don't really know how to read it or what it means. I have a picture of the untextured mob in game along with the BlockBench texture file and the lines of code on the console. Hope you can help.

Untitled document - Google Docs

Last seen on 13:45, 22. Jan 2021
Joined Oct 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Jimshoebob_jaZ just…
Sun, 11/29/2020 - 19:56

Jimshoebob_jaZ just requested access to the doc to see the problem. It could just be a few things you need to change on the mob.

Last seen on 13:45, 22. Jan 2021
Joined Oct 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
From what I can see, the…
Wed, 12/02/2020 - 14:51

From what I can see, the texture file might not be properly lined up with the blockbench models UV.