Entity rename error

Started by Juan Pablo Vega M. on Tue, 11/03/2020 - 15:05

Topic category: Bugs and solutions

Last seen on 14:13, 30. Dec 2020
Joined Nov 2020
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Entity rename error
Tue, 11/03/2020 - 15:05

Hello there!

I was creating a living entity, so I export the texture and the model to MCreator, but when I create another entity 

It tells me that the entity has the same name as custom_model, this had already happened to me, however I had solved it by changing the name of the entity manually but in this case now an error appears but I have tried to change the name a thousand times, Rename the java model the same and different from the class but it keeps coming out, I know they say that there is a solution by changing the name of the entity from blockbench but it has not worked for me, here below I leave the console error, please help me please :)

 

Executing Gradle task: build
Build info: MCreator 2020.4.32115, forge-1.15.2, 64-bit, 10178 MB, Windows 10, JVM 1.8.0_252, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk
> Configure project :
New Dep: net.minecraftforge:forge:1.15.2-31.2.0_mapped_snapshot_20200514-1.15.1
> Task :compileJava
C:\Users\Juan Pablo\Documents\Director\src\main\java\net\mcreator\orecraftmod\entity\FlamencoEntity.java:92: error: cannot find symbol return new MobRenderer(renderManager, new Flamenco(), 0.6f) {
^
symbol: class Flamenco
location: class FlamencoEntity
1 error
> Task :compileJava FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
* Get more help at https://help.gradle.org
Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.3/userguide/command_line_interface.html#se…
BUILD FAILED in 6s
1 actionable task: 1 executed
BUILD FAILED
Task completed in 12120 milliseconds
 

Last seen on 19:51, 25. Jan 2021
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I had solved it by changing…
Tue, 11/03/2020 - 18:01

I had solved it by changing the name of the entity manually

You did not rename it properly based on the log.

Please set the name in the modeler before exporting