A.I animations are messed up. Please help!

Started by rexyDos on Sat, 11/14/2020 - 19:59

Topic category: Help with MCreator software

Last seen on 10:18, 14. Aug 2021
Joined Aug 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
A.I animations are messed up. Please help!
Sat, 11/14/2020 - 19:59

Hello.

Recently I have been trying to add in an A.I to my mod. Everything is fine except for the pivot animations. I have tried everything I could yet the animations are still messed up. Ive watched videos even remade my model its self and I cant find what's wrong with it. Please Help! Thank you

Last seen on 13:52, 26. Sep 2021
Joined Oct 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Could you show us what is…
Sun, 11/15/2020 - 21:55

Could you show us what is happening with the models in-game? Preferably a short unlisted video of the entity moving around would work. Also if your using something like blockbench make sure the arm(s), leg(s) and head(s) are connected to the body via groups i.e. all arm parts in a group (This is only for 1 arm, don't put both left and right arms in the same group or the animation will mess up) (or multiple groups if there is more than 1 moving part) and then the arm part is connected to the body.

Example of how I would do the model layout for the Iron Golem

That's how I would layout my models groups for the iron golem model.