MCreator does not load the localization into the game at all.

Started by BigYajuu on Sat, 12/26/2020 - 10:02

Topic category: Troubleshooting, bugs, and solutions

Last seen on 10:33, 3. Jan 2021
Joined May 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
MCreator does not load the localization into the game at all.
Sat, 12/26/2020 - 10:02

Hello

I tried to migrate a mod from 1.12.2 to 1.14.4. I have done so on MCreator 2020.2.

But I am also planning on turning it into 1.15.2 and so on so forth, from this step onwards I cannot use 2020.2 MCreator anymore bcs MCreator 2020.2 does not support 1.15.2.

So I then use MCreator 2020.5, the latest stable build, to do migration work from 1.14.4 to 1.15.2.

But before I even managed to do that, I first have a problem with the existing 1.14.4 version of my mod  - that is the problem with localization.

When I ran the test environment on 2020.5, all of my translation works for my block names are not being displayed from the inventory. (The name should be in Simplified Chinese, but in reality it is still in English after I changed the Minecraft language setting) Only the creative tab names are translated.

What is the issue here?

Also I cannot use 2020.5 to straightaway migrating from 1.12.2 into 1.15.2. It just won't work.

Reply below is the complete console record for the test game session I have had with the mod. During the session, 1) I loaded and entered a creative world. 2) I switched my language from English to Chinese Simplified, and then 3) I saved and closed the game.

I noticed that the console also mentioned about the Gradle incompatability warning. Could this be caused by the fact that the mod was originally created from MCreator 2020.2?

 

I have deleted the log…
Sat, 12/26/2020 - 10:56

I have deleted the log. Please read https://mcreator.net/wiki/general-publishing-guidelines on how to post logs.

This topic which is probably duplicate from a few days ago might help too: https://mcreator.net/forum/68710/updating-modded-world-112-115