Mod launch issue in Minecraft

Started by MahyAss on Tue, 02/09/2021 - 16:25

Topic category: Help with modding (Java Edition)

Last seen on 15:14, 30. Apr 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Mod launch issue in Minecraft
Tue, 02/09/2021 - 16:25

Hello,

I can’t launch my mod in Minecraft.

https://pastebin.com/eg4ew6T7

Last seen on 16:29, 17. Mar 2021
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
well at the end it says…
Tue, 02/09/2021 - 16:31

well at the end it says wrong format, maybe ur mod names arent english or with weird symbols? idk

Last seen on 15:14, 30. Apr 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I changed the name of the…
Tue, 02/09/2021 - 16:41

I changed the name of the mod, but it doesn’t mark.

Last seen on 15:14, 30. Apr 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I added the GeckoLib mod but…
Tue, 02/09/2021 - 16:44

I added the GeckoLib mod but it still marks the same error message.

 

Last seen on 15:14, 30. Apr 2022
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The mod name does not have…
Tue, 02/09/2021 - 16:46

The mod name does not have to be in English.

java.lang…
Tue, 02/09/2021 - 16:50
  1. java.lang.NoClassDefFoundError: software/bernie/geckolib/entity/IAnimatedEntity

  2. at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_51]

  3. at java.lang.ClassLoader.defineClass(ClassLoader.java:760) ~[?:1.8.0_51]

  4. at java.lang.ClassLoader.defineClass(ClassLoader.java:642) ~[?:1.8.0_51]

This indicates a missing geckolib.

Also, unfortunately, I can't help you with plugins, so you may need to rely on the support of the plugin author, as I do not have the knowledge of the plugin.