[Solved] Mob or sometimes items has the id of "minecraft:air"...

Started by woodcraft on Sun, 02/28/2021 - 19:36

Topic category: Troubleshooting, bugs, and solutions

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[Solved] Mob or sometimes items has the id of "minecraft:air"...
Wed, 03/24/2021 - 23:21 (edited)

Heya!

When i create mobs or sometimes items they appear to not exist but you can still find them in the creative search but has the id of "minecraft:air".

Any ideas on what could be the cause?

Just wanted to add this is when loading the mod on a server but the mob / item in question works perfectly and exist in singleplayer.

Right now it's only a mob but a while back it was also an item which i have no clue how it started existing. 

Here is a picture of how it looks:

https://user-images.githubusercontent.com/63935963/109431170-630aa800-7…

MCreator: 2021.1 EAP (03117)

Edited by woodcraft on Wed, 03/24/2021 - 23:21
Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
And i tried to add more mobs…
Mon, 03/01/2021 - 00:35

And i tried to add more mobs and a command but none of them exists...

Last seen on 19:41, 14. Mar 2021
Joined Sep 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
hey, i had this exact same…
Mon, 03/01/2021 - 00:49

hey, i had this exact same issue a few weeks ago and only recently fixed it. do you have any GUIs linked to those items/mobs? GUIs to break things on the serverside and seemingly will be fixed in the next snapshot.

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Omg that makes sooo much…
Mon, 03/01/2021 - 00:54

Omg that makes sooo much sense thanks you for informing me!

Last seen on 13:10, 13. Apr 2021
Joined Jul 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
it sometimes the item or mob…
Mon, 03/01/2021 - 13:14

it sometimes the item or mob was to be, but it was bug, i found another bug from application and this will happen...

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Yeah idk but I'm really…
Thu, 03/04/2021 - 05:12

Yeah idk but I'm really confused since it's different on each server I try it on on a server with different mods everything works except for the mobs and when I do it on the integrated server all items disappear but the spawn eggs / mobs stay.... But yeah GUIs doesn't work on either

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
This is the error message i…
Thu, 03/04/2021 - 05:59

This is the error message i got from the integrated server:

[06:57:22] [main/DEBUG] [ne.mi.re.ObjectHolderRef/]: Unable to lookup creraces:fire_staff for public static net.minecraft.item.Item mc.sayda.creraces.item.FireStaffItem.block. This means the object wasn't registered. It's likely just mod options.

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
for one of the missing items…
Thu, 03/04/2021 - 05:59

for one of the missing items...

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The other servers debug log…
Thu, 03/04/2021 - 06:05

The other servers debug log is possible to be sent but it's really long and quite big and i do belive that the issue is releated since i found the same error messsage from the other server as the integrated one. The "Unable to lookup" error

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I'm just not sure what to do…
Thu, 03/04/2021 - 09:24

I'm just not sure what to do... I am however open to suggestions! if you might have another clue about whats going on please tell me, it's better than nothing!

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
bumping this since the…
Sun, 03/07/2021 - 12:33

bumping this since the problem still persists... I was just wondering if this problem is related to mcreators server side code or if it's something i can solve myself.

Last seen on 16:23, 14. Apr 2021
Joined Jan 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
SOLVED in the newest patch!
Wed, 03/24/2021 - 23:20

SOLVED in the newest patch!