GUI Build Error

Started by RedTShirtGaming on Tue, 05/04/2021 - 14:38

Topic category: Troubleshooting, bugs, and solutions

Last seen on 14:38, 30. May 2021
Joined May 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
GUI Build Error
Tue, 05/04/2021 - 14:38

I am making a GUI for a custom crafting table and after I save the mod element, it says build error and the console is showing an error message:

Executing Gradle task: build 
Build info: MCreator 2020.2.14217, 1.12.2, 64-bit, 15804 MB, Windows 10, JVM 1.8.0_232, JAVA_HOME: C:\Program Files\Pylo\MCreator\jdk 
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril. 
WARNING: You are using an unsupported version of ForgeGradle. 
Please consider upgrading to ForgeGradle 4 and helping in the efforts to get old versions working on the modern toolchain. 
See https://gist.github.com/TheCurle/fe7ad3ede188cbdd15c235cc75d52d4a for more info on contributing. 
:deobfCompileDummyTask 
:deobfProvidedDummyTask 
:sourceApiJava UP-TO-DATE 
:compileApiJava NO-SOURCE 
:processApiResources NO-SOURCE 
:apiClasses UP-TO-DATE 
:sourceMainJava 
C:\Users\timur\MCreatorWorkspaces\multimachines\build\sources\main\java\net\mcreator\multimachines\gui\GuiCoreCraftingGUI.java:274: error: unclosed string literal 
                this.fontRenderer.drawString("----------+"", 
                                                          ^ 
C:\Users\timur\MCreatorWorkspaces\multimachines\build\sources\main\java\net\mcreator\multimachines\gui\GuiCoreCraftingGUI.java:275: error: not a statement 
                    43, 38, -16777216); 
                    ^ 
C:\Users\timur\MCreatorWorkspaces\multimachines\build\sources\main\java\net\mcreator\multimachines\gui\GuiCoreCraftingGUI.java:275: error: ';' expected 
                    43, 38, -16777216); 
                      ^ 
3 errors 
:compileJava FAILED 
FAILURE: Build failed with an exception. 
* What went wrong: 
Execution failed for task ':compileJava'. 
> Compilation failed; see the compiler error output for details. 
* Try: 
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights. 
* Get more help at https://help.gradle.org 
BUILD FAILED in 1s 
5 actionable tasks: 4 executed, 1 up-to-date 
BUILD FAILED 
Task completed in 16350 milliseconds 

I tried remaking the GUI but the same error appears. Does anyone know why this is happening?

Thanks,

RedTShirtGaming :)