Custom Trees Problem

Started by KRIeator on Thu, 07/08/2021 - 09:01

Topic category: Troubleshooting, bugs, and solutions

Last seen on 08:13, 19. Sep 2021
Joined Jun 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Custom Trees Problem
Thu, 07/08/2021 - 09:01

I am working on a mod focusing on souls. I have created a soul forest biome, and I have made custom trees with custom blocks. When I tested the mod and went to that dimension, I can see the biome's main filler block, liquid, fog, entities, and everything, but can't see a single tree in it. I searched so far, and even though I had set the trees per chunk value to 4, I cant see a single tree. And I want my trees to be a little randomly generated with no fixed leaves shape so that it feels more natural, that's why I am not making a structure for the tree. Please help.

This could be a problem if…
Fri, 07/09/2021 - 05:34

This could be a problem if your ground isn't a block like grass which supports tree generation. You could also diversify your custom structure trees by making a few different models and allowing them to rotate and flip.

Last seen on 08:13, 19. Sep 2021
Joined Jun 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I recently made another…
Fri, 07/09/2021 - 10:37

I recently made another biome for testing and used the ground as brown terracotta, and surprisingly, it generated trees with slime block leaves and bone block stem. I deleted the Soul Forest biome and created another with the same generation settings but just with my custom soul log for stem and soul leaves for branches. I tested it and unfortunately, there was no tree generation. The main filler block and underground blocks were soul grass block and netherrack, this was the same in both the biomes I created, but still, the test biome had trees and the main one didn't. All the settings were literally the same! pls help I'm really confused.

Last seen on 08:13, 19. Sep 2021
Joined Jun 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I was just checking…
Fri, 07/09/2021 - 11:49

I was just checking everything in the biome and I saw the description of the main filler block. My block had to be tagged as a grass block. I made a tag for it and hopefully, it worked! I did not expect it would work. The trees started growing and everything is all fine. Thanks