[2021.2] Brewing Recipes are Broken

Started by Mystick Milotic on Fri, 09/03/2021 - 13:15

Topic category: Help with modding (Java Edition)

Last seen on 16:15, 23. Oct 2021
Joined Jun 2014
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
[2021.2] Brewing Recipes are Broken
Fri, 09/03/2021 - 13:15

When creating a custom brewing recipe, only the middle output slot of the brewing stand is available. The other two output slots act as normal (using vanilla recipes) while only this middle slot will output as per the custom recipe.

Last seen on 22:20, 23. Oct 2021
Joined May 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Have you tested this in the…
Fri, 09/03/2021 - 16:46

Have you tested this in the game? For me it works fine.

Are you trying to change a vanilla recipe and replace it with something else?

Last seen on 16:15, 23. Oct 2021
Joined Jun 2014
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I have tested it in game and…
Sat, 09/04/2021 - 09:43

I have tested it in game and that is what happens. I did try to override another recipe by placing glistening melons into the input slime blocks for an output just to test it, and only the middle brewing slot outputs the slime block. As far as I know, there are no recipe namespaces for brewing recipes? I scoured the internet for these and found nothing so overriding the vanilla recipes in the way i did seemed like the only way to do so, which does not work apparently.

You need to make sure stack…
Sat, 09/04/2021 - 11:04

You need to make sure stack size is 1, due to mc design of brewing recipes

Last seen on 16:15, 23. Oct 2021
Joined Jun 2014
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
In the middle of gathering…
Sat, 09/04/2021 - 11:19

In the middle of gathering images for some more insight into what I had done, it seems to have fixed itself. All I had done was open the mod element, closed it, then launched the test client. This is super strange.

Thank you for your responses.