Animated Geckolib Java entity crashing (medieval modpack)

Started by Smalish on Sun, 09/26/2021 - 16:04

Topic category: Help with MCreator software

Last seen on 11:13, 18. Oct 2021
Joined Sep 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Animated Geckolib Java entity crashing (medieval modpack)
Sun, 09/26/2021 - 16:13 (edited)

Hello, 

I'm new to modding and I decided to try my luck at making an animal mod for Minecraft 1.15.2 using MCreator, Blockbench and the Geckolib plugin on both of those.

I followed cautiously several Youtube tutorials and I understand how everything works on the surface. I also did everything that was mentioned in this very good GLib tutorial here and used the right versions of each applications, then watch some more videos.

So first thing first, I tried to work on my first animal, the red deer (a must have for anything medieval). I made the model, save the java file; made the texture, saved the png file; and then worked on a VERY simple walk animation, just to see if I can get it to work in the game, then saved it as a json file.

The problem is that, the entity doesn't spawn in the game despite going with a decently high spawning rate of 20 (more than most vanilla mobs), or the game crashes upon loading up the world (that I reset everytime).
Now, I also noticed that the pathway to the animation in the code always refer to a file simply called "red.deer", which does not exist in the folder, so I changed it manually and locked the code. 

The egg works though, I can make the deer spawn in the world, but it has no animations. I did try really hard to make it work though, but unsuccessfully, as you'll see in the pictures.

As you can see, my animation file has a different name. The same than on Blockbench, I tried to keep everything super tidy.

 

Here is the workspace.

 

Here is the bottom of the code, with the animation file manually modified.

 

Here is the trigger system I tried to make. The "while-do" at the end was my first attempt, didn't work either, obviously.

 

So there you go, hope you'll be able to tell me what I did wrong. Keep in mind that this is my first try at modding Minecraft, so Im still learning.
If you need any other infos, Ill be here to provide of course.

Thanks and have a nice day !

Edited by Smalish on Sun, 09/26/2021 - 16:13