Inconsistencies Overriding Vanilla Recipes

Started by Mindthemoods on Thu, 07/21/2022 - 18:13

Topic category: Troubleshooting, bugs, and solutions

Last seen on 20:08, 25. Sep 2022
Joined May 2022
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Inconsistencies Overriding Vanilla Recipes
Thu, 07/21/2022 - 18:13

I've been trying to override a couple of recipes to include some modded materials- specifically, the clock, lodestone, jukebox, and crossbow recipes. I've been able to successfully do this in the past by setting the recipe to use the 'Minecraft' directory and replacing it with the registry name of the recipe I want to replace. Previously, I was able to overwrite vanilla recipes, and even change whether they were shapeless or not. However, for some reason, these four recipes all refuse to work.

I've tried locking the code and modifying the existing code for each recipe from minecraft's data files, using this directory; I've also tested the same recipe tweaks with vanilla ingredients, and it still has no effect. Finally, I've tried loading the same recipe tweaks from previous projects into my current workspace, and they all work fine. It's just a couple of specific items that don't seem to want to have their recipes changed.

I'm almost certain I've got the names right, (Though it's worth noting Mcreator's list of Recipe registry names is not up to date.) Any ideas?