Not a Mod idea, but a Plugin idea: A 2021.1 plugin that allows 1.12.2 mods allows tool compatibility with Reskillable.

Started by RepeatsAlt on Wed, 08/24/2022 - 21:05

Topic category: Mod ideas exchange

Last seen on 20:20, 29. Aug 2022
Joined Oct 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Not a Mod idea, but a Plugin idea: A 2021.1 plugin that allows 1.12.2 mods allows tool compatibility with Reskillable.
Wed, 08/24/2022 - 21:05

I've noticed it's really hard to manually make a mod compatible with Reskillable unless they edit the config within a modpack (such as RLCraft), and was thinking, "What if there was some way to have automatic mod compatibility creation?" And so, I present the idea of a MCreator plugin for 1.12.2 that adds the ability to lock items behind certain skill levels. If this could be made, this would be amazing for mod creators who want to make mods for 1.12.2 modpacks such as RLCraft!

Reskillable Link

CompatSkills Link

CraftTweaker's Guide on CompatSkills