2022.3 - support for 1.19.2 seems complete, but 1.18.2 does not

Started by smmmadden on Mon, 11/07/2022 - 04:58

Topic category: Help with MCreator software

Last seen on 01:48, 29. Jan 2023
Joined May 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
2022.3 - support for 1.19.2 seems complete, but 1.18.2 does not
Mon, 11/07/2022 - 04:58

I've downloaded the latest build 2022.3 and in the settings, it shows 100% across the board for completed support for each feature.  However, if I change the version to generate the mod for 1.18.2, many features are not ready.  I rely a lot on advancements and procedures, so seeing these without 100% next to them is concerning.  Do I need to export the zip file and import to 2022.2 to generate the mod for 1.18.2 assuming of course this would work?

Regards,

Steve

1.18.2 can not support all…
Mon, 11/07/2022 - 17:55

1.18.2 can not support all features. 1.18.2, for example, can not support blocks that only exist in 1.19.2

To be more concrete, sculk was added in 1.19.2

You can not make a recipe with sculk in 1.18.2 because there is no such thing as sculk in 1.18.2

Last seen on 01:48, 29. Jan 2023
Joined May 2018
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
thanks Klemen, that makes…
Mon, 11/07/2022 - 19:15

thanks Klemen, that makes sense.  So as long as the procedures (as an example) are not introducing features specific to 1.19.2 (but will also work in 1.18.2), then compatibility should be okay to generate the mod for the previous version?  Thanks -Steve