LYIVX's Mod Compiler

Supported MCreator versions
2022.1
2022.2
2022.3
2023.1
2023.2
2023.3
2023.4
2024.1
Tags / plugin type
API support
LOGO
Downloads:
371
Upvotes: 4
About the plugin

This Plugin Allows You To Use Compiled Mod In Your MCreator Environment.


How To Use:

Enable The External API Called: 'Use Compiled Mods'

Now Go Inside Your MCreator Workspace Folder, You'll See A New Folder Called 'compile-mods-<minecraft-version>'.

In This Folder Is Where You Can Place All Your Mods You Want To Use


Currently Supported Minecraft Versions:

  • Forge - 1.16.5
  • Forge - 1.17.1
  • Forge - 1.18.1
  • Forge - 1.18.2
  • Forge - 1.19.2
  • Forge - 1.19.4
  • Forge - 1.20.1
  • NeoForge - 1.20.4

Warning:

Please Note That All Mods In The 'compile-mods' Folder Must Be Named Correctly:

    modname-minecraftversion-modversion.jar

Example:

    lyivxsfurnituremod-1.20.1-0.6.1

If The Mod Is Incorrectly Named Please Adjust It.


Disclaimer: This Plugin Was Originally Developed By Tarantel, (All Mods), But Seems To No Longer Be In Development.


Changelog:

Changelog - 1.1.1


Updated:

  • Added Support For 2024.1.15821



Changelog - 1.1.0


Updated:

  • Updated The Plugin For 2024.1

  • Added NeoForge 1.20.4


ALL PREVIOUS VERSIONS OF THE PLUGIN ARE AVAILABLE ON THE GIT REPOSITORY

Project members
Lead developer
Former developer
License
MIT License

Plugin downloads
LYIVX's Mod Compiler 1.1.1.zip - LYIVX's Mod Compiler 1.1.1.zipUploaded on: 04/13/2024 - 06:58   File size: 1.81 KB

Comments

I understand this is not your problem, but what should I do? My mod can be said to be broken. I have already made a post about this problem, I was told to contact the author of the plugin.

hello, after I clicked on "use the API to compile mods", my work environment was rebuilt as it should be, but after some mod elements broke and I had to disable the plugin API, after launching minecraft it stopped working, writes the following message "Error loading mods" "1 error durting load" "common_setup phase". I tried to look for a solution but nothing helped. How can I solve this?

Does this work with all mods? I downloaded Mystical Agriculture & Cucumber Library, which do not seem to work. I have also tried putting the mods in the run folder area where they would usually go to no success.