Bug when entering dimension.

Submitted by aditigro on Mon, 09/03/2018 - 10:40
Issue description

So I created a Dimension on 1.7.9 and when I entered it it shut down the internal system of minecraft.

After a while I tried again and it worked(I tink I remade the mod exactly the same) (still in 1.7.9)

Then I remade the mod in 1.8.0 and it gave the same error.

Edit: Here is the log:

   
Executing gradle command: clean runClient
Build info: MCreator 1.8.0, 64-bit, 3965 MB, Windows 10, JVM 1.8.0_172
F:\referate\MCreator180\forge>gradlew -Dorg.gradle.daemon=false -Dorg.gradle.parallel=false -Dorg.gradle.jvmargs="-Xms625m -Xmx2048m" clean runClient 
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
#################################################
         ForgeGradle 2.3-SNAPSHOT-ee3e3df        
  https://github.com/MinecraftForge/ForgeGradle  
#################################################
                 Powered by MCP                  
             http://modcoderpack.com             
     by: Searge, ProfMobius, R4wk, ZeuX          
     Fesh0r, IngisKahn, bspkrs, LexManos         
#################################################
:clean
:deobfCompileDummyTask
:deobfProvidedDummyTask
:sourceApiJava
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
:compileJava
:processResources
:classes
:jar
:getVersionJson
:extractNatives SKIPPED
:extractUserdev
:getAssetIndex UP-TO-DATE
:getAssets
Current status: 41/1305   3%
Current status: 103/1305   7%
Current status: 279/1305   21%
Current status: 558/1305   42%
Current status: 820/1305   62%
Current status: 1055/1305   80%
Current status: 1068/1305   81%
Current status: 1081/1305   82%
Current status: 1158/1305   88%
:makeStart
:runClient
2018-09-03 17:44:22,095 main WARN Disabling terminal, you're running in an unsupported environment.
[17:44:22] [main/INFO] [GradleStart]: Extra: []
[17:44:22] [main/INFO] [GradleStart]: Running with arguments: [--userProperties, {}, --assetsDir, C:/Users/Me/.mcreator/gradle/caches/minecraft/assets, --assetIndex, 1.12, --accessToken{REDACTED}, --version, 1.12.2, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
[17:44:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[17:44:22] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraftforge.fml.common.launcher.FMLTweaker
[17:44:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
[17:44:22] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLTweaker
[17:44:22] [main/INFO] [FML]: Forge Mod Loader version 14.23.4.2705 for Minecraft 1.12.2 loading
[17:44:22] [main/INFO] [FML]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_172, running on Windows 10:amd64:10.0, installed at F:\referate\MCreator180\jdk\jre
[17:44:22] [main/ERROR] [FML]: Apache Maven library folder was not in the format expected. Using default libraries directory.
[17:44:22] [main/ERROR] [FML]: Full: C:\Users\Me\.mcreator\gradle\caches\modules-2\files-2.1\org.apache.maven\maven-artifact\3.5.3\7dc72b6d6d8a6dced3d294ed54c2cc3515ade9f4\maven-artifact-3.5.3.jar
[17:44:22] [main/ERROR] [FML]: Trimmed: c:/users/me/.mcreator/gradle/caches/modules-2/files-2.1/org.apache.maven/maven-artifact/3.5.3/
[17:44:22] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
[17:44:22] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLCorePlugin (net.minecraftforge.fml.relauncher.FMLCorePlugin), we are in deobf and it's a forge core plugin
[17:44:22] [main/INFO] [FML]: Ignoring missing certificate for coremod FMLForgePlugin (net.minecraftforge.classloading.FMLForgePlugin), we are in deobf and it's a forge core plugin
[17:44:22] [main/INFO] [FML]: Searching F:\referate\MCreator180\forge\run\.\mods for mods
[17:44:22] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
[17:44:22] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.fml.relauncher.FMLCorePlugin
[17:44:22] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
[17:44:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:44:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[17:44:22] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[17:44:23] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:44:23] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLInjectionAndSortingTweaker
[17:44:23] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[17:44:25] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
[17:44:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper
[17:44:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.FMLDeobfTweaker
[17:44:26] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
[17:44:26] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.fml.common.launcher.TerminalTweaker
[17:44:26] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.fml.common.launcher.TerminalTweaker
[17:44:26] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[17:44:27] [main/INFO] [net.minecraft.client.Minecraft]: Setting user: Player765
[17:44:34] [main/WARN] [net.minecraft.client.settings.GameSettings]: Skipping bad option: lastServer:
[17:44:34] [main/INFO] [net.minecraft.client.Minecraft]: LWJGL Version: 2.9.4
[17:44:35] [main/INFO] [FML]: -- System Details --
Details:
   Minecraft Version: 1.12.2
   Operating System: Windows 10 (amd64) version 10.0
   Java Version: 1.8.0_172, Oracle Corporation
   Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
   Memory: 138694896 bytes (132 MB) / 430440448 bytes (410 MB) up to 924844032 bytes (882 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
   FML: 
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 388.13' Renderer: 'GeForce GT 730/PCIe/SSE2'
[17:44:35] [main/INFO] [FML]: MinecraftForge v14.23.4.2705 Initialized
[17:44:35] [main/INFO] [FML]: Starts to replace vanilla recipe ingredients with ore ingredients.
[17:44:35] [main/INFO] [FML]: Replaced 1036 ore ingredients
[17:44:36] [main/INFO] [FML]: Searching F:\referate\MCreator180\forge\run\.\mods for mods
[17:44:38] [main/INFO] [FML]: Mod testenvironmentmod is missing the required element 'name'. Substituting testenvironmentmod
[17:44:38] [main/INFO] [FML]: Forge Mod Loader has identified 5 mods to load
[17:44:38] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at CLIENT
[17:44:38] [main/INFO] [FML]: Attempting connection with missing mods [minecraft, mcp, FML, forge, testenvironmentmod] at SERVER
[17:44:38] [Thread-3/INFO] [FML]: Using sync timing. 200 frames of Display.update took 222564348 nanos
[17:44:40] [main/INFO] [net.minecraft.client.resources.SimpleReloadableResourceManager]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:testenvironmentmod
[17:44:40] [main/INFO] [FML]: Processing ObjectHolder annotations
[17:44:40] [main/INFO] [FML]: Found 1168 ObjectHolder annotations
[17:44:40] [main/INFO] [FML]: Identifying ItemStackHolder annotations
[17:44:40] [main/INFO] [FML]: Found 0 ItemStackHolder annotations
[17:44:40] [main/INFO] [FML]: Configured a dormant chunk cache size of 0
[17:44:40] [main/INFO] [FML]: OBJLoader: Domain testenvironmentmod has been added.
[17:44:40] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Starting version check at http://files.minecraftforge.net/maven/net/minecraftforge/forge/promotio…
[17:44:41] [main/INFO] [FML]: Applying holder lookups
[17:44:41] [main/INFO] [FML]: Holder lookups applied
[17:44:41] [main/INFO] [FML]: Applying holder lookups
[17:44:41] [main/INFO] [FML]: Holder lookups applied
[17:44:41] [main/INFO] [FML]: Applying holder lookups
[17:44:41] [main/INFO] [FML]: Holder lookups applied
[17:44:41] [main/INFO] [FML]: Applying holder lookups
[17:44:41] [main/INFO] [FML]: Holder lookups applied
[17:44:41] [main/INFO] [FML]: Injecting itemstacks
[17:44:41] [main/INFO] [FML]: Itemstack injection complete
[17:44:41] [Forge Version Check/INFO] [forge.VersionCheck]: [forge] Found status: UP_TO_DATE Target: null
[17:44:43] [Sound Library Loader/INFO] [net.minecraft.client.audio.SoundManager]: Starting up SoundSystem...
[17:44:44] [Thread-5/INFO] [net.minecraft.client.audio.SoundManager]: Initializing LWJGL OpenAL
[17:44:44] [Thread-5/INFO] [net.minecraft.client.audio.SoundManager]: (The LWJGL binding of OpenAL.  For more information, see http://www.lwjgl.org)
[17:44:45] [Thread-5/INFO] [net.minecraft.client.audio.SoundManager]: OpenAL initialized.
[17:44:45] [Sound Library Loader/INFO] [net.minecraft.client.audio.SoundManager]: Sound engine started
[17:44:49] [main/INFO] [FML]: Max texture size: 16384
[17:44:49] [main/INFO] [net.minecraft.client.renderer.texture.TextureMap]: Created: 512x512 textures-atlas
[17:44:52] [main/INFO] [FML]: Applying holder lookups
[17:44:52] [main/INFO] [FML]: Holder lookups applied
[17:44:52] [main/INFO] [FML]: Injecting itemstacks
[17:44:52] [main/INFO] [FML]: Itemstack injection complete
[17:44:52] [main/WARN] [FML]: No types have been added to Biome testenvironmentmod:fantasticfield, types have been assigned on a best-effort guess: [HILLS]
[17:44:52] [main/WARN] [FML]: No types have been added to Biome testenvironmentmod:darkforest, types have been assigned on a best-effort guess: [FOREST, DENSE, HILLS]
[17:44:52] [main/WARN] [FML]: No types have been added to Biome testenvironmentmod:desertofdespair, types have been assigned on a best-effort guess: [DRY, SANDY, PLAINS]
[17:44:52] [main/WARN] [FML]: No types have been added to Biome testenvironmentmod:frozenmountains, types have been assigned on a best-effort guess: [DRY, PLAINS]
[17:44:53] [main/INFO] [FML]: Forge Mod Loader has successfully loaded 5 mods
[17:44:53] [main/WARN] [net.minecraft.client.settings.GameSettings]: Skipping bad option: lastServer:
[17:44:53] [main/INFO] [com.mojang.text2speech.NarratorWindows]: Narrator library for x64 successfully loaded
[17:44:55] [Realms Notification Availability checker #1/INFO] [com.mojang.realmsclient.client.RealmsClient]: Could not authorize you against Realms server: Invalid session id
[17:45:00] [Server thread/INFO] [net.minecraft.server.integrated.IntegratedServer]: Starting integrated minecraft server version 1.12.2
[17:45:00] [Server thread/INFO] [net.minecraft.server.integrated.IntegratedServer]: Generating keypair
[17:45:00] [Server thread/INFO] [FML]: Injecting existing registry data into this server instance
[17:45:01] [Server thread/INFO] [FML]: Applying holder lookups
[17:45:01] [Server thread/INFO] [FML]: Holder lookups applied
[17:45:01] [Server thread/INFO] [FML]: Loading dimension 0 (New Worl) (net.minecraft.server.integrated.IntegratedServer@572656fb)
[17:45:02] [Server thread/INFO] [net.minecraft.advancements.AdvancementList]: Loaded 488 advancements
[17:45:02] [Server thread/INFO] [FML]: Loading dimension 5 (New Worl) (net.minecraft.server.integrated.IntegratedServer@572656fb)
[17:45:02] [Server thread/INFO] [FML]: Loading dimension 1 (New Worl) (net.minecraft.server.integrated.IntegratedServer@572656fb)
[17:45:02] [Server thread/INFO] [FML]: Loading dimension -1 (New Worl) (net.minecraft.server.integrated.IntegratedServer@572656fb)
[17:45:02] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Preparing start region for level 0
[17:45:03] [Server thread/INFO] [FML]: Unloading dimension -1
[17:45:03] [Server thread/INFO] [FML]: Unloading dimension 1
[17:45:03] [Server thread/INFO] [net.minecraft.server.integrated.IntegratedServer]: Changing view distance to 2, from 10
[17:45:05] [Netty Local Client IO #0/INFO] [FML]: Server protocol version 2
[17:45:05] [Netty Server IO #1/INFO] [FML]: Client protocol version 2
[17:45:05] [Netty Server IO #1/INFO] [FML]: Client attempting to join with 5 mods : minecraft@1.12.2,FML@8.0.99.99,testenvironmentmod@1.0,forge@14.23.4.2705,mcp@9.42
[17:45:05] [Netty Local Client IO #0/INFO] [FML]: [Netty Local Client IO #0] Client side modded connection established
[17:45:05] [Server thread/INFO] [FML]: [Server thread] Server side modded connection established
[17:45:05] [Server thread/INFO] [net.minecraft.server.management.PlayerList]: Player765[local:E:82406802] logged in with entity id 43 at (-1077.5, 11.001335979112147, -226.9522052040959)
[17:45:05] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Player765 joined the game
[17:45:07] [Server thread/INFO] [net.minecraft.server.integrated.IntegratedServer]: Saving and pausing game...
[17:45:07] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving chunks for level 'New Worl'/overworld
[17:45:07] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving chunks for level 'New Worl'/fantasticrealm
[17:45:08] [pool-2-thread-1/WARN] [com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService]: Couldn't look up profile properties for com.mojang.authlib.GameProfile@16408e07[id=5f90bf1f-575d-3542-89d7-731859eee6f2,name=Player765,properties={},legacy=false]
com.mojang.authlib.exceptions.AuthenticationException: The client has sent too many requests within a certain amount of time
   at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.makeRequest(YggdrasilAuthenticationService.java:79) ~[YggdrasilAuthenticationService.class:?]
   at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService.fillGameProfile(YggdrasilMinecraftSessionService.java:180) [YggdrasilMinecraftSessionService.class:?]
   at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService$1.load(YggdrasilMinecraftSessionService.java:60) [YggdrasilMinecraftSessionService$1.class:?]
   at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService$1.load(YggdrasilMinecraftSessionService.java:57) [YggdrasilMinecraftSessionService$1.class:?]
   at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3716) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2424) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2298) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2211) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache.get(LocalCache.java:4154) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4158) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5147) [guava-21.0.jar:?]
   at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5153) [guava-21.0.jar:?]
   at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService.fillProfileProperties(YggdrasilMinecraftSessionService.java:170) [YggdrasilMinecraftSessionService.class:?]
   at net.minecraft.client.Minecraft.getProfileProperties(Minecraft.java:3178) [Minecraft.class:?]
   at net.minecraft.client.resources.SkinManager$3.run(SkinManager.java:138) [SkinManager$3.class:?]
   at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_172]
   at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_172]
   at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_172]
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_172]
   at java.lang.Thread.run(Thread.java:748) [?:1.8.0_172]
[17:45:09] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Stopping server
[17:45:09] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving players
[17:45:09] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving worlds
[17:45:09] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving chunks for level 'New Worl'/overworld
[17:45:09] [Server thread/INFO] [net.minecraft.server.MinecraftServer]: Saving chunks for level 'New Worl'/fantasticrealm
[17:45:10] [Server thread/INFO] [FML]: Unloading dimension 0
[17:45:10] [Server thread/INFO] [FML]: Unloading dimension 5
[17:45:10] [Server thread/INFO] [FML]: Applying holder lookups
[17:45:10] [Server thread/INFO] [FML]: Holder lookups applied
[17:45:11] [main/FATAL] [net.minecraft.client.Minecraft]: Unreported exception thrown!
java.lang.NullPointerException: null
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:45) ~[PositionedSoundRecord.class:?]
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:40) ~[PositionedSoundRecord.class:?]
   at net.minecraft.client.multiplayer.WorldClient.playSound(WorldClient.java:509) ~[WorldClient.class:?]
   at mod.mcreator.mcreator_fantasticRealm$BlockCustomPortal.randomDisplayTick(mcreator_fantasticRealm.java:584) ~[mcreator_fantasticRealm$BlockCustomPortal.class:?]
-> Jump to the exception line
   at net.minecraft.client.multiplayer.WorldClient.showBarrierParticles(WorldClient.java:391) ~[WorldClient.class:?]
   at net.minecraft.client.multiplayer.WorldClient.doVoidFogParticles(WorldClient.java:379) ~[WorldClient.class:?]
   at net.minecraft.client.Minecraft.runTick(Minecraft.java:2019) ~[Minecraft.class:?]
   at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:1186) ~[Minecraft.class:?]
   at net.minecraft.client.Minecraft.run(Minecraft.java:441) [Minecraft.class:?]
   at net.minecraft.client.main.Main.main(Main.java:118) [Main.class:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_172]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_172]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_172]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_172]
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_172]
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_172]
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_172]
   at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_172]
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97) [start/:?]
   at GradleStart.main(GradleStart.java:25) [start/:?]
[17:45:11] [main/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:629 ---- Minecraft Crash Report ----
// Quite honestly, I wouldn't worry myself about that.
Time: 9/3/18 5:45 PM
Description: Unexpected error
java.lang.NullPointerException: Unexpected error
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:45)
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:40)
   at net.minecraft.client.multiplayer.WorldClient.playSound(WorldClient.java:509)
   at mod.mcreator.mcreator_fantasticRealm$BlockCustomPortal.randomDisplayTick(mcreator_fantasticRealm.java:584)
-> Jump to the exception line
   at net.minecraft.client.multiplayer.WorldClient.showBarrierParticles(WorldClient.java:391)
   at net.minecraft.client.multiplayer.WorldClient.doVoidFogParticles(WorldClient.java:379)
   at net.minecraft.client.Minecraft.runTick(Minecraft.java:2019)
   at net.minecraft.client.Minecraft.runGameLoop(Minecraft.java:1186)
   at net.minecraft.client.Minecraft.run(Minecraft.java:441)
   at net.minecraft.client.main.Main.main(Main.java:118)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
   at GradleStart.main(GradleStart.java:25)
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
-- Head --
Thread: Client thread
Stacktrace:
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:45)
   at net.minecraft.client.audio.PositionedSoundRecord.(PositionedSoundRecord.java:40)
   at net.minecraft.client.multiplayer.WorldClient.playSound(WorldClient.java:509)
   at mod.mcreator.mcreator_fantasticRealm$BlockCustomPortal.randomDisplayTick(mcreator_fantasticRealm.java:584)
-> Jump to the exception line
   at net.minecraft.client.multiplayer.WorldClient.showBarrierParticles(WorldClient.java:391)
   at net.minecraft.client.multiplayer.WorldClient.doVoidFogParticles(WorldClient.java:379)
-- Affected level --
Details:
   Level name: MpServer
   All players: 1 total; [EntityPlayerSP['Player765'/43, l='MpServer', x=-1077.50, y=11.00, z=-226.95]]
   Chunk stats: MultiplayerChunkCache: 49, 49
   Level seed: 0
   Level generator: ID 01 - flat, ver 0. Features enabled: false
   Level generator options: 
   Level spawn location: World: (-1095,4,-225), Chunk: (at 9,0,15 in -69,-15; contains blocks -1104,0,-240 to -1089,255,-225), Region: (-3,-1; contains chunks -96,-32 to -65,-1, blocks -1536,0,-512 to -1025,255,-1)
   Level time: 965 game time, 965 day time
   Level dimension: 0
   Level storage version: 0x00000 - Unknown?
   Level weather: Rain time: 0 (now: false), thunder time: 0 (now: false)
   Level game mode: Game mode: creative (ID 1). Hardcore: false. Cheats: false
   Forced entities: 1 total; [EntityPlayerSP['Player765'/43, l='MpServer', x=-1077.50, y=11.00, z=-226.95]]
   Retry entities: 0 total; []
   Server brand: fml,forge
   Server type: Integrated singleplayer server
Stacktrace:
   at net.minecraft.client.multiplayer.WorldClient.addWorldInfoToCrashReport(WorldClient.java:461)
   at net.minecraft.client.Minecraft.addGraphicsAndWorldToCrashReport(Minecraft.java:2886)
   at net.minecraft.client.Minecraft.run(Minecraft.java:470)
   at net.minecraft.client.main.Main.main(Main.java:118)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
   at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
   at GradleStart.main(GradleStart.java:25)
-- System Details --
Details:
   Minecraft Version: 1.12.2
   Operating System: Windows 10 (amd64) version 10.0
   Java Version: 1.8.0_172, Oracle Corporation
   Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
   Memory: 183858752 bytes (175 MB) / 472907776 bytes (451 MB) up to 924844032 bytes (882 MB)
   JVM Flags: 0 total; 
   IntCache: cache: 0, tcache: 0, allocated: 1, tallocated: 14
   FML: MCP 9.42 Powered by Forge 14.23.4.2705 5 mods loaded, 5 mods active
   States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
   | State     | ID                 | Version      | Source                           | Signature |
   |:--------- |:------------------ |:------------ |:-------------------------------- |:--------- |
   | UCHIJAAAA | minecraft          | 1.12.2       | minecraft.jar                    | None      |
   | UCHIJAAAA | mcp                | 9.42         | minecraft.jar                    | None      |
   | UCHIJAAAA | FML                | 8.0.99.99    | forgeSrc-1.12.2-14.23.4.2705.jar | None      |
   | UCHIJAAAA | forge              | 14.23.4.2705 | forgeSrc-1.12.2-14.23.4.2705.jar | None      |
   | UCHIJAAAA | testenvironmentmod | 1.0          | modid-1.0.jar                    | None      |
   Loaded coremods (and transformers): 
   GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 388.13' Renderer: 'GeForce GT 730/PCIe/SSE2'
   Launched Version: 1.12.2
   LWJGL: 2.9.4
   OpenGL: GeForce GT 730/PCIe/SSE2 GL version 4.6.0 NVIDIA 388.13, NVIDIA Corporation
   GL Caps: Using GL 1.3 multitexturing.
Using GL 1.3 texture combiners.
Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
Shaders are available because OpenGL 2.1 is supported.
VBOs are available because OpenGL 1.5 is supported.
   Using VBOs: Yes
   Is Modded: Definitely; Client brand changed to 'fml,forge'
   Type: Client (map_client.txt)
   Resource Packs: 
   Current Language: English (US)
   Profiler Position: N/A (disabled)
   CPU: 2x Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz
[17:45:11] [main/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:printToSYSOUT:629 #@!@# Game crashed! Crash report saved to: #@!@# F:\referate\MCreator180\forge\run\.\crash-reports\crash-2018-09-03_17.45.11-client.txt
AL lib: (EE) alc_cleanup: 1 device not closed
:runClient FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':runClient'.
> Process 'command 'F:\referate\MCreator180\jdk\bin\java.exe'' finished with non-zero exit value -1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 2 mins 5.531 secs
F:\referate\MCreator180\forge>
Task completed with return code 0 in 126882 milliseconds

 

Attachment Size
BugWithDimension.mcr144.46 KB 144.46 KB

Issue comments

Submitted by Klemen on Mon, 09/03/2018 - 13:00

Copy the full text you get in the console tab of MCreator when the Minecraft crashes when you enter the dimension and paste it in the ticket. Thanks!

Submitted by Klemen on Mon, 09/03/2018 - 15:20

Thank you very much. Would you mind attaching the workspace .mcr file too? I thought I would be able to find the bug by error log only, but it seems that I will need more info. Thanks again!

Submitted by Klemen on Wed, 09/05/2018 - 11:17

Thanks, I will look at this issue and try to fix it.

Submitted by aditigro on Wed, 09/05/2018 - 12:23

By playing with the new version I came across multiple bugs. I reported this one first because I considered it most annoying. I thought I should ask you wether to "spam" them one by one everyday or wait some time before reporting the next one?

P.S I know this is unrelated to this issue but I didn't know where to ask you.

Submitted by Klemen on Wed, 09/05/2018 - 12:54

There are just two persons working on MCreator right now so if there are too many unimportant bugs reported, it is hard to filter out important ones and the development is slowed down this way.

Klemen, I know you get this all the time.
I am having the same issue with the dimensions.

The other day I follow the wiki to create my biome and then my dimension and it all worked fin.

Strangely enough I did the same again but with all my textures and add-ons. When I ignite the portal it crashes as say server is shutting down. Was wonder is this could be cause by the fact that I created a item called igniter and then gave the dimension igniter the same name? However even after deleting those items and recipes I can not even load the world after the crash. I am trying to recreate the crash to find where it may be but it is long as it take about 20mins to compile my world when I delete and item/recipe/etc as it is huge... Any suggestions?

Okay, so I fix the bug on this one. Its a conflict between the igniter that you choose in the dimension you create and a trying to make another like it. AS when I deleted them from the mod and re used a back of the world all worked correctly. However I was only able to to ignite the dimension via creative mode as that is the only place the igniter works... I would love to know how to make the igniter get called up or even apply a recipe to it. I have been trying via procedure but have had no luck yet as I can not call the item at hand in any shape or fashion! Thanks 

The bug you said about was different from the one I reported. I encountered your's too but couldn't recreate it.

The difference is that my bug crushes the game when in the dimension, not in the overworld after igniting the portal.

Submitted by Klemen on Sat, 10/06/2018 - 08:45

It seems that if you leave sound empty, the portal block will crash the game. Just select one of the sounds on the list and it will work. I will add support for empty sound for the portal block in 1.8.1 so I am closing this ticket.

Submitted by aditigro on Sat, 10/06/2018 - 09:52

Is it the one I reported or the one that also crashes in the overworld?