My mob won't deal any damage

Status
Outdated
Type
Product/platform
Not applicable
Priority
Normal
Issue description

I am a new user of MCreator and I have been trying unsuccessfully to make an agressive mob. I've set the task "act agressively against" and "attack on collide", set the damage value to 10, set the type of mob to mob(which is agressive), but the mob is not able to deal damage. It just gets close to the target like a magnet and does nothing but that. Please, help.

Thank you,

A random user. (I am sorry if this is a duplicate too, but I am dealing with a ton of problems with MCreator and I need help)

Issue comments

Sorry if I posted this on the wrong field. This is a support request, not a bug problem

Yes. These are some of the commands though:

Attack on collide with (zombie)

Act agressively against (zombie)

Look around

Walk around

Swimming ability

Look at closest mob

Well, I think I found what the problem was:When I entered the command "attack targets, make mob agressive" the hitbox was fine and so was the damage dealing. Weird, but I finally did it. FINALLY.

Well, I tried again and the problem still exists when i changed the mob's health from 10 to 20 and lowered the damage.

Yes, but even then some damage should have been dealt.(Because the damage value of the mod is 8 along with the sword it is wielding)

I have checked and this worked in MCreator 1.8.0. You did not specify the MCreator version so I am assuming you are not using the latest version.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.