Crash on runclient

Upvotes: 0
Issue description

Today I downloaded Mcreator 1.8.1, so I exported the workspace of Mcreator 1.8.0 into MCreator 1.8.1.

The first time I imported the workspace it said it was older than 1.7.9 (and that was a 1.8.0 workspace) and I pressed ok. It imported the workspace in very little time but it actually imported nothing. It didn't import any mod elements/textures/etc.

So I tried to import it again and I had the same issue.

I thought that MCreator 1.8.0 generated an empty mcr file, so I tried to export the workspace again (with a different name).

I closed and opened again MCreator 1.8.1, then imported the new workspace.

It didn't say that the workspace was older than 1.7.9 and it imported all the elements.

I thought it was working fine, until I pressed runclient and had this error:

https://pastebin.com/CB75UmF2

Issue comments

I tried to runclient an empty workspace and I had the same error :(

Developer Submitted by Klemen on Mon, 11/05/2018 - 19:37

This bug is not related to 1.8.1. You are having Couldn't set pixel format org.lwjgl.LWJGLException: Pixel format not accelerated  error.

This error usually means that you have an unsupported graphics card for Minecraft our outdated graphics card drivers. This page could help:

One of the users also reported reinstalling Minecraft on his computer fixed this bug.

Check this ticket for more info: https://mcreator.net/tracker/issue/44848

Minecraft using vanilla launcher works fine.

I tried to uninstall and reinstall it, but I still have the error.

I tried to update the drivers but it seems that there are no updates available...

Developer Submitted by Klemen on Tue, 11/06/2018 - 05:17

But in MCreator 1.8.0 or 1.7.9, Minecrafts starts after you started getting this error in 1.8.1?

Try installing Minecraft Forge 2768 in your Minecraft and test if it works or crashes too.

Developer Submitted by Klemen on Tue, 11/06/2018 - 15:08

Or this one:

Go to <installation dir>\forge\run\config and edit the splash.properties file and set enabled setting to false.

Please report back if any of this helped.

I tried to download the recommended version of Minecraft forge and run it in the minecraft launcher (and forge worked, however I still had that error on Mcreator). Then I tried to runclient older Mcreator versions but they didn't work too.
Now I will try the solutions you wrote in the last 2 comments (I have just seen them XD)

Developer Submitted by Klemen on Tue, 11/06/2018 - 19:42

If older versions stopped to work too, I guess this was caused by a recent graphics driver update that could happen even without you knowing.

This is a known issue when developing mods "by hand" too. When launching test Minecraft this sometimes happens too other developers too and some of the fixes I found on the internet include these listed above.

I've tried, but I have no nvidea drivers and there is no config folder in that directory :(

I have just noticed you released a new patch

I will try to download it (there is no harm in trying)

Developer Submitted by Klemen on Thu, 11/08/2018 - 15:35

Even if you don't have Nvidia GPU, you can still try to downgrade the drivers you have for the GPU as this is my main suspect right now.

Regarding the splash.properties that is missing, you can copy it from another MCreator installation which has it and change it as described in my previous comments. Many users have reported for this method to work for them.

I've tried to roll back my driver and it didn't work.

How should I open the splash.properties file? If I try to open it using Notepad++ it is just a list of null characters

Nevermind, Mcreator works fine now (I can runclient with no errors)

Developer Submitted by Klemen on Sat, 11/10/2018 - 09:20

Glad to hear your first issue got resolved. Please open a separate issue for this new error, and please attach the workspace and instructions on how to reproduce this error too. Thanks!

Submitted by OmniMC on Tue, 11/20/2018 - 12:59

Easiest fix is to revert to Java Runtime Environment 1.8.0_25 though MCreator constantly wants to use 1.8.0_191 even if you remove it from your device. I'm unsure of how to solve that part.