Mod is not compatible with latest forge versions

Status
Duplicate
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I tried to load the mod in the most recent Forge version at that time, and the error message: This mod is meant for forge 1.1.1.2 and you have 1.1.1.3 popped up (Not exact of course). 

Issue comments

In MCreator 1.8.2 we have added Minecraft Forge version tag as a dependency as many users used MCreator with different versions Minecraft Forge than with the one MCreator used to compile mods. This caused many crashes and errors due to version mismatches. We added this dependency to resolve this issue.

Check this issue for more info and a not recommended workaround: https://mcreator.net/tracker/issue/46740

I will see if checking for versions higher than the given version is possible. If you find any examples of such code, you are welcome too.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.