Cannot set Burn Fuel Power Manually forced to use arrows on side to set values

Published by raziel23x on Mon, 08/19/2019 - 16:25
Upvotes: 1
Issue description

Like the title say for example listed https://mcreator.net/wiki/burn-time-fuels

 

I was making a fuel block that is 10 times more then lava bucket which is 200000 so i cleared out the 1,600 default setting and just manually typed in 200,000 then clicked  save mod element but it reverts back to 1,600 which when i click on it to see if what i saw it revert back to when i clicked saved the values i typed in..... it was set back to the default settings....... but if i used the arrows on the side to adjust the values and save they will save correctly but if i type in the amount even using the comma  yet it will revert back to what ever value i adjusted it to with the arrows not what i typed into the box. I have ended up just setting the correct value and locking the java code manually...

 

 

EDIT Fixed mistakes as i mean to say 200 000 not 20 000

Issue comments

Enter the value without commas. 200,00 is not valid formatting for 20000. You need to group zeroes by three, this is a normal standard. But to avoid this issue altogether, just enter the value without any dots or commas.

I have tried to enter 20000 and it worked on my PC so I can't say why this does not work for you. Could you provide a screen recording of what is happening?

Ok, I see, I miscounted the number of zeroes. I will increase the number limit in 1.9.1. Thank you for providing the details :)

Max number is limited by Java, but we will set it to the largest value that is acceptable to work fine.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.