Slabs Recipes not WORKING in v1.12 and sometime in v1.14

Published by KreatorB on Sun, 04/05/2020 - 04:06
Status
Can not reproduce
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

Slabs Recipes not WORKING in v1.12 or v1.14
If you require a copy of my files I can provide it to you, just let me know how!
If I am not mistake when I made the move to 2020.2 I tested the slabs and recipes and I believe they worked!
I also tested my 1.12 version in 1.14 but converting it and the problem still occurred

In the 1.14 version I created a new slab and recipe and they seemed to work but none of the previous ones did!

I replied in an older issue about this same problem, however decided to re-post as the other issue stated you could not recreate the issue again.
Sorry, I know you are busy!
 

Issue comments

I also tested my 1.12 version in 1.14 but converting it and the problem still occurred

In the 1.14 version I created a new slab and recipe and they seemed to work but none of the previous ones did!

So in 1.14 now works or not because in the first sentence you said 1.14 does not work and in the next one that it does.

I would need your files, yes, I was not able to reproduce this in 1.14.4.

But please for 1.14.4 as 1.12.2 will not be supported in 2020.3. Attach the workspace.

I got it to work in 1.14 by opening the old recipe that was created in 1.12 and saving it over again. That seemed to activate it. However the 1.12 does not work, even if I create a new recipe or re-save an old one.
I am testing a new workspace for 1.12 and it seems that the issue of the recipe is 1.12 with slabs only!
 

okay I also took a copy of the working slabs in 1.14 and converted back to 1.12 and that did not work either. Slabs in 1.12 seem to be buggin.  Hope These details help. Let me know if you need a copy of my files and how to send them!

I have noted that you marked this issue as "Can not reproduce" I can reproduce this issue.
I am providing you the steps to help in the issue reproduction!

 

1. Create a new workspace v1.12

2. create or import 2 textures to test with

3. create a block with one of the textures

4. create a slab with the other texture

5. create a recipe for the slab

6. run client to test

7. check to see if recipe works in game version 1.12

8. If you like convert the 1.12 version to 1.14 and test in there.

9. If you do, converts slab recipes will function and if they do not you may need to open a few and re-save them is all.

 

I really hope this helps and that you will find it in your power to help fix this bug for the users/community of version 1.12 as this is the missing piece in the long await part of the puzzle.

Once again Thank you for understanding and helping.

Please let me know if you require anything that I can provide to make this bug go away!

 

THANKS

 

 

was wondering if any of this info helped and if you got to see the bug yourself...

I have come across a potential fix/work around.

Using the following Mods for 1.12 which are found on https://www.curseforge.com/minecraft/mc-mods/

You will be able to add them to your gradle/run folder and create the recipes needed.
A file will be created under the gradle/scripts folder and the file will house all the recipes for your users.

However you will need to make sure that you add to the API/External MOD requirements that this mods are required and the script file is also required. While this sucks butt, it is the only way to now fix the final slab stages of the 1.12.2 of MCreator app as the support is not gone for 1.12.

 

Hope this helps

KreatorB

 



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.