Text inside textfield procedure block not working

Published by Hidan on Sat, 04/11/2020 - 16:28
Status
Migrated
Type
Product/platform
Not applicable
Priority
Normal
Issue description

So I have noticed 2 small issues with CGui elements

1. Text input boxes are moved to top left side of the screen when game window is resized
2. Button does not run procedures properly in some cases, "Send message to players chat" procedure block is not executed when bounded to button
also it updates the block NBT'tags but it does not update them in gui text

Attachment Size
GUI Bug_0.zip337.89 KB 337.89 KB

Issue comments

Please provide a workspace that has these problems as especially the NBT tags parts is something I do not experience when testing. Thanks!

Here is your workspace, to check this bug place Telepad somewhere and right click on it "No Energy is required or other stuff"

If your game is on fullscreen than input boxes will be away from the gui
also when you input coordinates, they should appear on the bottom left side of the gui and message should appear in chat box but I assume that it will not gonna appear so I added Print block in it too, also when you input coordinates and try to bind them than all of them will be set to -1 :L

Do you use any custom plugins? I can't seem to get the workspace to work due to missing procedure blocks.

"Send message to players chat" procedure block is not executed when bounded to button

I have tried clicking the button and the text was shown to the player, although the text was in fact not correct. I am changing this ticket to a bug report of getting text field value not working.

1. Text input boxes are moved to top left side of the screen when game window is resized

For this issue, please open a separate ticket as you reported two separate issues in this one and this is against our rules. One can be fixed sooner as the other but will not be closed by this ticket.

Oki, do you still need my plugin?

It is not related to my gui but I can send it if required also will this also gonna fix the issue with incorrect values being taken from text field? 

No need, I figured which procedures to remove.

It is not related to my gui but I can send it if required also will this also gonna fix the issue with incorrect values being taken from text field? 

Yes, this ticket covers this problem. But I have not found a solution yet.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.