Custom recipes that alter vanilla stop working after 2020.3

Status
Resolved
Type
Product/platform
MCreator/Windows
Priority
Normal
Issue description

I updated my mod from 2020.2 (1.14.4) to 2020.3 (1.15.2) and my custom recipes that alter vanilla stop working. For example, my mod have recipes that changes stone tools recipe, replacing cobblestone to stone. Now this recipes stop working and only normal recipe works.There is workspace: https://drive.google.com/open?id=1jZEyb2rlmFL37oEnELFrzVHnvwITilyZ . Sorry for my English if something not clear.

Issue comments

1;31:58.30 [Server thread/ERROR] [minecraft/RecipeManager]: Parsing error loading recipe pootismod:arcticalloyingotsmelt
com.google.gson.JsonSyntaxException: Unknown item 'pootismod:arcticmix'

and

1;31:58.30 [Server thread/ERROR] [minecraft/RecipeManager]: Parsing error loading recipe minecraft:chest
com.google.gson.JsonSyntaxException: Unknown item tag 'minecraft:craftingplates'

These two recipes refer to unknown elements. Unknown items break crafting system.

 

I suggest fixing or removing these recipes.

If they no longer exits, remove them manually from the recipes folder.

Hmm, I have tested your recipes in 1.14.4 and they did not work either. Are you sure this worked before?

I think I found the problem. Forge adds some recipe overrides to and your overrides get overridden by forge overrides.

Seems sorting is quite unpredictable and based on the modid so you might have to try some modids to find the right one.

I made another workspace and tested this (only added one recipe override) in it and the recipe was overriden.

This worked for me:

  1. I completely removed all recipes folders both for minecraft and mod namespace
  2. Changed modid to "atest"
  3. Launched MC and overrides started to work

Sorry, but I don't know either in this case. Try different modids, if this does not help, I am out of ideas, it worked for me by steps I provided above.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.