Import Blockly's Modern Theme

Status
Resolved
Product/platform
Not applicable
Priority
Normal
Issue description

So blockly editor has themes

Now we're using the Classic theme, but the Modern theme looks much better.

https://blockly-demo.appspot.com/static/tests/playground.html

Choose modern to see the effects

Issue comments

Current WebKit used is default JavaFX renderer and breaks with releases that add new renderers and themes from Blockly.

Using these versions makes it unusable due to rendering glitches.

There are two options at this point:

  1. Move to Chromium. In works https://mcreator.net/tracker/issue/57093, but JCEF is far from a production-ready state
  2. Update to newer Java, but this would break building due to Java 8 being the recommended version for mods (most MC instances still run on Java 8)

I will reference this ticket from the previously mentioned ticket, but right now this is not possible.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.