Corrupt caches

Status
Resolved
Type
Product/platform
MCreator/macOS
Priority
Normal
Issue description

a few weeks back i got corrupt cahes error while working on my mod i chose clear caches folder option and i had to go through the long gradle setup. it worked fine. yesterday i get the same error i chose "do nothing" this time but it kept giving me failed errors so i exited mcreator. today i deleted the caches folder and waited more than 2 hours for the setup to finish and as soon as it was done and i clicked workspace and i got the corrupt caches error again . i exited and deleted the caches folder. i didnt reopen mcreator since because i dont wanna wait more than 2 hrs again for it to give me the same error,  is there any solution, and what keeps corrupting the caches is there a way to avoid getting them corrupt?? also can the things the setup downloads be available as a manual download from the website as i think it would be more convenient to download with a download manager then put them in the right directory than waiting alot of time in the app.

 

thanks.

Issue comments

Most of the time caches get corrupted by software like antivirus programs. It is a wide spread known problem that even Windows Defender can greatly interfere with Gradle build system. Consider adding gradle folder in .mcreator and workspace folders as exceptions.

hello i dont have any antivirus or somrthing that can block it also im on MacOs so no windows defender

Something is doing it. Caches are managed by Gradle. Try googling Gradle caches problem Mac or something like this. I don't have (and can't afford) Mac to test this for you.



Donate to MCreator

By donating to developers you can speed up development, as with more resources, we can dedicate more time to MCreator. It is a free project made by developers working on it in their free time.