Custom mobs not spawning in custom dimension (Still no answer)

Started by ribkix on Sat, 01/02/2021 - 17:13

Topic category: Help with modding (Java Edition)

Last seen on 16:21, 17. Jan 2021
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Custom mobs not spawning in custom dimension (Still no answer)
Thu, 01/07/2021 - 19:46 (edited)

Hello I am trying to make a dimension where I spawn my custom mob, but they aren't spawning. I've looked through all Google pages, all MCreator forum pages and nothing helps.
Mob spawn settings:
Mob spawn settings

utilimod:electrite_forest is the biome throughout the whole dimension, but it's not working.

Edited by ribkix on Thu, 01/07/2021 - 19:46
Last seen on 21:53, 10. Jun 2022
Joined Aug 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Try to define it in the…
Sun, 01/03/2021 - 12:59

Try to define it in the biome too, if it doesn't work I don't know what can be happening. Maybe there are other creatures in the biome that have a higher probability of appearing, making that mob very rare.

Last seen on 16:21, 17. Jan 2021
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I've already tried doing…
Sun, 01/03/2021 - 13:01

I've already tried doing that, and there are no other creatures spawning in the biome. Since this mob is actually a monster, I've also tried doing monster instead of creature but that also doesn't help.

Last seen on 23:34, 16. May 2022
Joined Apr 2020
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
While defining a mob for…
Sun, 01/03/2021 - 14:51

While defining a mob for spawning, I noticed if you define it in both the dimension and the mob, it can cause a multiply effect, causing it to just keep spawning.

Here's what I think your problem is.

  • A mob marked as Creature will spawn under direct sunlight on grass material blocks only. Do not use this spawn type with mob type living entities as they will not spawn

What I think is happening is your top block is not a grass block material, so as a result, no mobs are spawning.

Last seen on 16:21, 17. Jan 2021
Joined Jan 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
It is, let me show you, in…
Sun, 01/03/2021 - 17:38

It is, let me show you, in the biome I have set it to this block:
Biome ground block

and this block's material is grass:
Grass material

Last seen on 21:41, 20. Jun 2022
Joined Jul 2017
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I have this issue too
Fri, 04/09/2021 - 00:20

I have this issue too

Last seen on 03:47, 30. Jun 2022
Joined Feb 2021
Points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Been over a year and this…
Wed, 05/25/2022 - 04:28

Been over a year and this still isn't fixed