MrCrayFish Model Creator help

Started by AwesomeDrewSauce1476 on Thu, 03/03/2016 - 22:03
Last seen on 17:23, 2. Sep 2018
Joined Oct 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
MrCrayFish Model Creator help
Thu, 03/03/2016 - 22:03

I was on the mr crayfish model creator making a model. I finished the model and exported it as a json. I imported it and did the textures, but when I got on mcreator, it did a purple and black error texture for the block.

Last seen on 21:34, 15. Aug 2018
Joined Jul 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Did it pop up a box asking
Sun, 03/06/2016 - 05:18

Did it pop up a box asking for the textures when you imported the models? Or do you mean the textures were purple and black when you ran the test client?

Last seen on 18:08, 1. Mar 2018
Joined Apr 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I'm having a alightly
Sun, 03/06/2016 - 14:59

I'm having a alightly diffreent problem, all my textures for the .json model are the same, there only shows 1 texture, the model works fine and it comes up on mcreator with me being able to input different textures for the model when I inport the model, but its only ever the first texture

Last seen on 21:34, 15. Aug 2018
Joined Jul 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
OK. To fix this, you will
Sun, 03/06/2016 - 17:47

OK. To fix this, you will need to edit the files in the Mcreator folders. 

Go to your MCreator165 folder (C:\Pylo\MCreator165 (or whatever version your'e using)).

Now, go to the "user" folder.

Open "json" folder, then open "models," then "block."

You should see a list of all blocks you've imported/created. Find the one you're having a problem with, and open the file (You should use notepad to edit any .json files). 

If you see "Blockname.json" and "BlockName_custom.json", open the one without "_custom."

Now you should see the names of the textures. For example, "textures":{  "0": "blocks/water_still" or something like this (this may only look like this if you're using MrCrayfish model creator.

If you have a number in front of the texture in the file, open the "Blockname_custom.json" to figure out what number corresponds to each texture.

To change the textures, change the "blocks/yourtexture" for each one. (If they all say "blocks/water_still," change the ones without water to "blocks/othertextures.") If the numbers and textures match up in the _custom.json and the .json, you should be good.

Go to "Save As", change the ".txt" default and change it to "All Files." It will overwrite the previous file, but should have the right textures now. 

Close MCreator (if it's open) and reopen it, now run the client and the textures should be fixed.

Hope this helps, I know it's pretty lengthy but I wanted to make sure you understood the process.

I know this will work for the problem with the same textures, I'm not sure about the error textures. Try it anyway.

Last seen on 17:23, 2. Sep 2018
Joined Oct 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Sorry that I didn't respond
Sun, 04/17/2016 - 15:34

Sorry that I didn't respond in forever. No one was responding so I gave up on this post.

Last seen on 03:50, 12. Aug 2018
Joined Aug 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
This is my problem, but your
Thu, 09/29/2016 - 16:46

This is my problem, but your instruction are pretty hard to follow :/

Im using Mr Crayfish Model maker to export my .json model, but when I load my .json in the block creator of mCreator for minecraft 1.10 it asks me for 3 "part" textures. I already mapped my textures in Mr Crayfish, and exported to a .model file as well, but following through with the wonky block creation process only yields me a 3D block covered in pink and black squares.

Is mCreator still just broken or is this a problem with Mr. Crayfish? Im leaning towards mCreator, as Ive had similar problems importing models from blender. 

Any help would be appreciated. It would be a deal breaker to be forced to use vanilla textures for every custom item.

Last seen on 20:07, 20. Jan 2017
Joined Jan 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I've created a custom model
Fri, 01/20/2017 - 20:07

I've created a custom model jukebox using you model creator (which made if fantastically easy, thank you!) but have a couple small issues I've not been able to figure out how to fix:

1) Whatever block is adjacent to the jukebox becomes invisible on the touching side;

2) The model will only place facing in one direction.

Any suggestions on how to fix this?

http://imgur.com/a/imyVa