No texture for armor items

Started by Araraura on Fri, 04/28/2017 - 18:21

Topic category: Help with MCreator's application

Last seen on 07:33, 5. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
No texture for armor items
Fri, 04/28/2017 - 18:21

I Tried making a mod that adds an armor to the game, but for some reason, the armor doesn't have an item texture. when you wear it, you have your armor, but when you hold it in your hand, it's the black and purple missing texture.

Last seen on 04:31, 22. Aug 2019
Joined Mar 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
  • moderator
are you sure the texture for
Sat, 04/29/2017 - 06:39

are you sure the texture for the armor pieces is a perfect square (ex. 16x16, 100x100, etc)

Last seen on 07:33, 5. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:are you sure the texture for
Sat, 04/29/2017 - 06:57

@#1 They all are

Last seen on 07:33, 5. May 2017
Joined Apr 2017
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
RE:are you sure the texture for
Sat, 04/29/2017 - 11:38

@#1 now what?

Last seen on 23:44, 18. Aug 2019
Joined Apr 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
If you are using Mcreator 1.7
Sat, 04/29/2017 - 16:10

If you are using Mcreator 1.7.5, the held item textures for armor are bugged so that the texture will not work. \

I have yet to find anyone who knows a solution to this. Sorry

Last seen on 22:52, 27. Oct 2017
Joined Nov 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
I have seen some mods what
Sat, 04/29/2017 - 18:58

I have seen some mods what have been updated with armor but the makers are not posting there fix's, this as been the case with EVERY update what brakes things, some users don't want to share there fix's what is really upsetting.

Last seen on 12:09, 5. Feb 2019
Joined Oct 2015
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
To me the same happens to me
Sun, 05/07/2017 - 11:10

To me the same happens to me and I can not find a solution, have you found it?

Last seen on 22:52, 27. Oct 2017
Joined Nov 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Nope and also seems the bug's
Sun, 05/07/2017 - 14:51

Nope and also seems the bug's at times are also selective, I watched one youtuber at the moment creating a chest and works, some replied it creashed there MCr, I followed the video and yep I also crash out.

So these bugs are nuts

Last seen on 23:44, 18. Aug 2019
Joined Apr 2016
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
You could try my fix for
Sun, 05/07/2017 - 16:37

You could try my fix for missing item/block textures, although it did not work for me with armor.

1-Go into your resources tab on the left side of the mod workspace

2-click on the texture that is missing and delete it. Ignore the warning it gives you

3-go back to edit the thing that had the missing texture and just re-upload it