My MCreator doesn't work

Started by CrazyJerz on Thu, 07/13/2017 - 16:37

Topic category: Bugs and solutions

Last seen on 17:51, 23. Dec 2018
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
My MCreator doesn't work
Thu, 07/13/2017 - 16:37

My MCreator doesn't work. I don't know why. How can I fix it?
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
Microsoft Windows [Version 10.0.15063]
(c) 2017 Microsoft Corporation. Wszelkie prawa zastrzeľone.
C:\Pylo\MCreator175>cd forge
C:\Pylo\MCreator175\forge>SET "JAVA_HOME=C:\Pylo\MCreator175\jdk32\"
C:\Pylo\MCreator175\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator175\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator175\forge>gradlew -Dorg.gradle.jvmargs="-Xms512m -Xmx1024m" cleanCache clean setupDecompWorkspace --refresh-dependencies
Download http://files.minecraftforge.net/maven/net/minecraftforge/gradle/ForgeGr…
This mapping 'snapshot_20161220' was designed for MC 1.11! Use at your own peril.
#################################################
         ForgeGradle 2.2-SNAPSHOT-f0ba31b       
  https://github.com/MinecraftForge/ForgeGradle 
#################################################
               Powered by MCP unknown              
             http://modcoderpack.com            
         by: Searge, ProfMobius, Fesh0r,        
         R4wk, ZeuX, IngisKahn, bspkrs          
#################################################
:cleanCache
:clean UP-TO-DATE
:deobfCompileDummyTask
:deobfProvidedDummyTask
:getVersionJson
:extractUserdev
:extractDependencyATs SKIPPED
:extractMcpData
:extractMcpMappings
:genSrgs
:downloadClient
:downloadServer
:splitServerJar
:mergeJars
:deobfMcSRG
Applying SpecialSource...
Applying Exceptor...
:decompileMc
Error occurred during initialization of VM
Could not reserve enough space for 3145728KB object heap
:decompileMc FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':decompileMc'.
> Process 'command 'C:\Pylo\MCreator175\jdk32\bin\java.exe'' finished with non-zero exit value 1
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
BUILD FAILED
Total time: 9 mins 36.485 secs
C:\Pylo\MCreator175\forge>
Task completed with return code 0 in 578708 milliseconds

Last seen on 19:55, 28. Sep 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
I think that it's a RAM error
Thu, 07/13/2017 - 16:41

I think that it's a RAM error.
Try to allocate more RAM to MCreator by the MCreator Settings

Last seen on 17:51, 23. Dec 2018
Joined Jan 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:I think that it's a RAM error
Thu, 07/13/2017 - 16:59

@#1 how much ram?

Last seen on 19:55, 28. Sep 2020
Joined Jun 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
RE:RE:I think that it's a RAM error
Thu, 07/13/2017 - 17:01

I don't know, just set more ram (and see the maximal RAM of the computer)
If this doesn't work try to use the 64bit version of MCreator