Mod can't run on 1.12.2 / needs 1.11.2

Started by Vision Quester on Sun, 11/12/2017 - 21:05

Topic category: Help with MCreator software

Last seen on 08:33, 9. Apr 2020
Joined Nov 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Mod can't run on 1.12.2 / needs 1.11.2
Sun, 11/12/2017 - 21:05

Hey, all.  I'm just starting out with MCreator.  Very nice.  I like the simplicity.

I made my first test.  Created a new block, hard to break, added other features.  Exported the jar file, and inserted it into Minecraft's mods folder.

When I launch Forge, it tells me that my mod can't run on Minecraft 1.12.2, but requires 1.11.2.  Is there something I need to do when exporting?  Or should I simply downgrade my Minecraft to 1.11.2?

Thanks.

 

Last seen on 08:33, 9. Apr 2020
Joined Nov 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
A little further... I think…
Sun, 11/12/2017 - 21:22

A little further... I think I found the answer... in another thread that referred to the green progress bar showing MCreator 1.12.2's progress.

Any word yet on how much longer it will be?

Last seen on 08:33, 9. Apr 2020
Joined Nov 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Update... Found the solution…
Sun, 11/12/2017 - 22:43

Update... Found the solution for any other newbies having this problem.

In your Minecraft launcher, click "Launch Options" near the top of the launcher.  This opens a list showing all your Minecraft and Forge loading presets.

Create a new preset for Forge 1.11.2 by clicking "Add New" near the top left.  A form with the following fields opens up:

Name: (You can name this preset any way you like.)

Version: (In this drop down, scroll to the very bottom and select "release 1.11.2-forge[with a bunch of other numbers following it]".)

Game directory: (Where your Minecraft 1.11.2 executable file is located.  Select this Minecraft exe using the directory buttonto the  right.)

Java executable: (Where your "javaw.exe" is located.  Select "javaw.exe" using the directory button to the right.)

The final two fields just leave as they are.

Now you click "News" near the top of the page, get back to the launcher, and across the bottom you should see the launch preset you just created in the dropdown list.  This will now launch Forge 1.11.2 and Minecraft 1.11.2.

Last seen on 08:33, 9. Apr 2020
Joined Nov 2017
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Oppse.  The game directory…
Sun, 11/12/2017 - 22:51

Oppse.  The game directory is just to your roaming/.minecraft folder.  There's no file to select here; you just find your .minecraft folder.