1.7.10 Forge Ranged Mob Error [Custom code, advanced error]

Started by KBEHAN on Fri, 08/17/2018 - 22:21

Topic category: Advanced modding

Last seen on 23:21, 14. Apr 2019
Joined Jul 2015
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
1.7.10 Forge Ranged Mob Error [Custom code, advanced error]
Fri, 08/17/2018 - 22:21

For people who know how to code in minecraft (specifically 1.7.10),  I tried making a custom mob that shoots a custom entity throwable projectile.  Everything has compiled correctly but crashes a few seconds after when I spawn the entity.  It gives me a ticking entity error. 

here is the error: https://hastebin.com/ikiwicatur.sql

 

Here is my code: https://hastebin.com/zepesotola.java

 

I am led to believe it might be a "byte" error but I am not sure.  Please help.

Last seen on 00:21, 11. Aug 2019
Joined Aug 2013
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
The "ticking entity" is not…
Fri, 08/17/2018 - 23:12

The "ticking entity" is not the error. It just says when the actual error has occured, in this case - during an entity tick. The actual error is java.lang.NullPointerException. That means that some variable used either in your code or in a code that your code fires is null.

And if you look just two lines under the error, you can see where it has been used - line 205. Because you are using a really outdated version of MC + my sources are 1.12.2, I do not know the code of the DataWatcher class of your version, but the value that you are trying to update or get is never added to the entity on its init.