Problem when recompiling workspace

Started by Bengee867 on Sat, 11/24/2018 - 20:42

Topic category: Help with modding (Java Edition)

Last seen on 22:41, 7. Sep 2019
Joined Apr 2016
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
Problem when recompiling workspace
Sat, 11/24/2018 - 20:42

I am creating a road mod, and all that I have made so far is a guard rail. The model was made with Techne, but when I recompile the workspace I get a error. This is what comes in in the grandle log:

C:\Pylo\MCreator173\forge\build\sources\java\mod\mcreator\mcreator_crashBarrier.java:211: error: variable Shape1 is already defined in class ModelGuardRail1
		ModelRenderer Shape1;
		              ^
C:\Pylo\MCreator173\forge\build\sources\java\mod\mcreator\mcreator_crashBarrier.java:212: error: variable Shape1 is already defined in class ModelGuardRail1
		ModelRenderer Shape1;
		              ^
2 errors

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileJava'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

I am really confused and would appreciate some help :)

Last seen on 19:38, 26. Oct 2020
Joined Apr 2010
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • MCreator plugins:
  • Comments:
You have made multiple…
Sun, 11/25/2018 - 10:24

You have made multiple elements of your custom mob model that have a same name. You can't do this. Fix your model in Techne, export it again and import it again.