A Problem With Slot Triggers

Started by Nuclear_Maker on Sun, 02/10/2019 - 07:20

Topic category: Help with MCreator's application

Last seen on 20:43, 14. Feb 2019
Joined Apr 2018
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
A Problem With Slot Triggers
Sun, 02/10/2019 - 07:30 (edited)

Hi everyone I was having some problems with gui slots for my mod.

I was making a furnace for my mod. I made the procedures for it (There is two of them, one for checking slots and another for opening the gui) and  after completing the gui I make the slot 0 to check for items when there is a item inside it but it seems like when I put an item it does not trigger. But instead right click (Take half of the stack) triggers the slot.

 

Is it supposed to be like that?

Or this is a bug?

If anybody has an answer please let me know it would help me a lot on my mod.

EDIT:By the way version is 1.8.2.

Edited by Nuclear_Maker on Sun, 02/10/2019 - 07:30
Last seen on 15:45, 15. Apr 2019
Joined Apr 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
  • wiki contributor
Did your procedure was…
Mon, 02/11/2019 - 03:29

Did your procedure was assigned to on block tick update trigger? If not than assign it to that trigger also you need to use procedure block that removes one item from slot

Last seen on 20:43, 14. Feb 2019
Joined Apr 2018
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Yes Thanks After Looking for…
Mon, 02/11/2019 - 13:41

Yes Thanks After Looking for problems I saw that my procedure set to check every time i right click to the block.So it was stupid of me.But thans for helping :)