Custom Crafting GUI Doesn't Work in Multiplayer

Started by rmsandegs on Thu, 07/04/2019 - 22:17

Topic category: Help with MCreator modding

Last seen on 00:17, 23. Jul 2019
Joined May 2014
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Custom Crafting GUI Doesn't Work in Multiplayer
Thu, 07/04/2019 - 22:17

My custom GUI only has 2 slots. When the first 2 have specific items in them, the user clicks an on-screen button. The crafted item then appears in the third slot.

Unfortunately, this is not the case in multiplayer. The GUI does not execute the procedure at all when the button is pressed. The strange thing is, when I make the procedure run on a redstone signal to the crafting block, it works! This is pretty confusing for me.

The GUI inherits the custom crafting block, and the block has 3 slots- I made sure of that.

I've tried everything I can think of and nothing's worked. Mu GUI is structured similarly to the one in this video: https://www.youtube.com/watch?v=qdGJY7ljujM

Any ideas?