My custom block made with blockbench is not working

Started by Flawgic on Wed, 07/17/2019 - 17:49

Topic category: Help with MCreator software

Last seen on 20:01, 15. May 2020
Joined Jul 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
My custom block made with blockbench is not working
Wed, 07/17/2019 - 17:49

I have made an anvil, from scratch, but whenever I place it ingame, it does a weird twist, enlarges, and becomes completely black.

This is my model in blockbench: http://prntscr.com/ogex2m

This is the block mod element in MCreator: http://prntscr.com/ogeyzm

This is how it looks like ingame: http://prntscr.com/ogf01a

 

If anyone requires more information, im willing to provide

I will appreciate any sort of help I can get, thanks!

Last seen on 20:01, 15. May 2020
Joined Jul 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
Nevermind, Ive solved it.  …
Wed, 07/17/2019 - 19:24

Nevermind, Ive solved it.

 

For some reason, OBJ+MTL was giving Mcreator a hard time. I tried importing JSON instead and it worked perfectly fine. I am not sure if this issue is from something I did, but just letting anyone know if theres someone whos dealing with this problem too for some reason god knows.

Last seen on 23:52, 5. Jul 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
how to export to .json
Mon, 07/29/2019 - 01:42

how to export to .json

Last seen on 18:50, 26. Jun 2020
Joined Mar 2018
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
you need to make java block…
Tue, 12/31/2019 - 17:16

you need to make java block/item or convert to it in blockbench then you must click export blockmodel, don't give item/block geometry name and don't set ambient oclusion to true, idk if it would crash your block but mine always crashes when i have ambient oclusion on true

Last seen on 23:52, 5. Jul 2020
Joined Jun 2019
User points:

User statistics:

  • Modifications:
  • Forum topics:
  • Wiki pages:
  • Tracker tickets:
  • Comments:
OKay thx I fixed it a long…
Tue, 12/31/2019 - 23:22

OKay thx

I fixed it a long time ago