Bug: Achievements do not work & Creative Tabs icons are invisible when using selective vanilla textures as icon

Started by StellaeLux on Mon, 10/07/2019 - 15:02

Topic category: Bugs and solutions

Last seen on 15:12, 21. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Bug: Achievements do not work & Creative Tabs icons are invisible when using selective vanilla textures as icon
Wed, 10/09/2019 - 12:20 (edited)

If you are working with achievements and noticed that some work and some don't: This is due to a bug that causes an achievement to be unobtainable when it has a vanilla texture as icon. Changing the icon to a custom one will solve the problem.

I assume the same principle is true when it comes to creative tabs if your pictures aren'y showing up when selecting vanilla textures.

Edited by StellaeLux on Wed, 10/09/2019 - 12:20
Last seen on 04:26, 14. Oct 2019
Joined Sep 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
(No subject)
Mon, 10/07/2019 - 21:36

imageimage

Last seen on 15:12, 21. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
It might be a mac only issue…
Mon, 10/07/2019 - 21:37

It might be a mac only issue. Strange that you weren't able to replicate my result.

Last seen on 04:26, 14. Oct 2019
Joined Sep 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Yeah might be only a mac…
Mon, 10/07/2019 - 21:44

Yeah might be only a mac thing or some of them do break it I only tested one texture.

Last seen on 15:12, 21. Nov 2019
Joined Aug 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Okey, I don't think it's a…
Mon, 10/07/2019 - 23:13

Okey, I don't think it's a mac only issue. Using BLOCK.bed for example is invisible as tab, while grass works fine for me.

I tried BLOCK.bed for achievement but it worked fine there to my surprise. If only I had tested which vanilla texture I picked when causing the issue. I switched between my custom texture and that texture 2 times to ensure this was really the case.

Last seen on 04:26, 14. Oct 2019
Joined Sep 2019
User points:

Statistics:

  • Comments:
  • Forum topics:
  • Modifications:
  • Wiki pages:
Yep I can confirm that…
Mon, 10/07/2019 - 23:36

Yep I can confirm that selecting block.bed texture for a creative tab icon will not be visible as the creative tab icon in game.

This sounds like a specific…
Wed, 10/09/2019 - 10:57

This sounds like a specific of said item. I suggest to make custom "bed" item for a tab in such case.